1

I've been using my MacBook Pro for years and it was still working fine. For the last year or two I was using Yosemite, it was working without any significant problems.

Yesterday I decided to update to Sierra. Mid 2010 MBP supports this version, so I decided to have a try.

The latest OS X version was downloaded from the AppStore, unarchived, installed. The installation (that claimed to last 34 minutes) took longer - about 3 hours. Finally it rebooted and loaded to the screen where I was asked to login with AppleID. However, there was no login/password field, only the label "login with your AppleID" and two disabled buttons ("back" and "next"). There was some empty space to fit the textfields for login and password, but it was just the empty space. I waited for some time, tried to do something, but there were no variants. So I powered my Macbook off.

When I turned it back again, I noticed that the loading (white screen, Apple logo, progress bar) took longer than usual. It slowed down reaching the half of the progress bar, but finally reached the end and stopped. I waited for another hour. Nothing happened. Apple logo and the full progress bar.

Tried to Safe Boot. It took a while, but finally I saw my desktop, a popup window with the new Sierra features, etc.

I decided that the first freeze was just a one-time error and turned the Macbook off again.

Since then I am unable to boot in either the normal mode, or SafeBoot mode. The only things I am able to do are the Recovery mode, the verbose mode and the single-user mode. I was not able to perform the hardware diagnostics mode (which is called something different in 2010 MBP) either.

I've tried reseting PRAM and SMC - no changes, the frozen Apple logo and the progress bar are still there.

Since I was able to access the recovery mode, I have tried the Disk Utility's First Aid. It told me, that everything is fine.

I tried to reinstall the OS, as I thought it will roll me back to Lion (or what was there by default..?). But the Sierra installation popped up again. I waited for another full round of Sierra installation. It rebooted, but with no luck. It still does not get past the boot part.

Finally here is what I get in the verbose mode. The Macbook was left overnight, and now I can tell there are a few stages.

Firstly it scrolls through some lines, which are different. There are some things, that look like errors to me. Like:

Photo

Then the lines begin to appear slower:

Photo

After that it comes to a very long sequence of AMFI exceptions. Like that:

Photo Photo

This goes on for a while. The number before "because" is increasing. And after a few hours this AMFI exceptions become rearer. The number in brackets is more than 4000 now.

The final stage I witness right now is the following:

Photo

There are looping blocks of lines about GTK, SmartBattery, "_peerManager is missing", and some rare AMFI's.

I really don't know what to do, Everything was working just fine before I tried to update. Now it is a mess. I tried to search the web, but all I found were some unanswered questions.

  • You may erase the /private/var/db/.AppleSetupDone file in Single User Mode and repeat your setup or restore the backup you made before upgrading. – klanomath Dec 23 '16 at 18:16
  • I'll try the first one right now – Deimos Dec 23 '16 at 18:21
  • You (hopefully) will be asked to create a new user. From there it's easier to diagnose your problem. – klanomath Dec 23 '16 at 18:24
  • So, I delete the file in Single-user mode and reinstall the OS X from the Recovery mode, right? Or do I just try to boot once again? – Deimos Dec 23 '16 at 18:29
  • I would blur the PMK/TPIK keys and your mac address pairs if you don't want to share them with the rest of the world from the screens, as a precaution. – PJJ Dec 23 '16 at 18:30

You must log in to answer this question.

Browse other questions tagged .