13

Recently I started seeing News notifications on my Apple Watch:

enter image description here

I've confirmed that News is turned off in the Watch app on my iPhone under Notifications:

enter image description here

But I keep getting the notifications. I've tried turning News notifications on, and then off again. But I keep getting them.

Am I unaware of some other necessary setting that will disable these notifications?

  • 1
    I'm having the same problem, such an odd bug. – wfbarksdale Mar 16 '17 at 15:27
8

Actually I was having the same problem and discovered why. In the News app itself there are some notification settings. Why it's so obscure and hard to find is unlike Apple, but it's there all the same.

Go to the News app and tap on the Favorites tab. At the very top you'll see three things: a bell gliph, a Favorites option (for sorting), and an Edit button. Tap on the bell gliph. It's for configuring the notifications.

Favorites screen

From there it's pretty self explanatory. You can turn on or off all notifications right there. It doesn't explicitly say Apple Watch notifications, but they are somehow intrinsically connected. I disabled all of them and it stopped harassing me on my watch.

They really should make the notification options separate for iOS and the watch. Seems dumb how I have to go in to a place that makes no sense just to turn off stuff.

Incidentally you can also stop the annoying barrage of default news sources here on the Favorites screen. Just hit Edit and remove them.

  • The best option would've been to edit the existing answer to point out the additional steps. As it is, there's two similar answers with slightly different info and this could confuse anyone else who has the same problem. – fsb Feb 28 '17 at 13:42
  • 2
    Please keep answers fact-based and focused. Different people will have different reasons for deselecting the default news sources, but the procedure to remove them is the same for everybody. – nohillside Mar 1 '17 at 11:08
3

I agree with Morpheus. I actually spent a lot of time on the phone with Apple support today with the same issue. Three different support specialists (one senior), and none of them had a solution.

My solution was to go into the news app and shut off all the alerts I really didn't care about. It's a work around for now until the next update fixes it.

2

I have been having the same issue. It must be a bug. Please report it to Apple here:

http://www.apple.com/feedback/watch.html

  • This should be a comment, not an answer. (But thanks.) – Daryl Spitzer Dec 23 '16 at 22:05
  • 2
    Actually - this is a clear answer. Morpheus is saying it's purely a bug (and by implication - no settings will help anyone change this behavior). Whether this answer is right or wrong is debatable (please vote) but it's not a comment asking for clarification of the question, so calling for this to be a comment isn't how the site is set up. – bmike Dec 23 '16 at 22:42
  • 1
    It seems more like an answer now that it's been edited. – Daryl Spitzer Dec 24 '16 at 17:08
1

I deleted the News app just now. Hope that stops the notifications. Workaround will do for now until there is a solution.

You must log in to answer this question.

protected by Community Jul 24 '17 at 18:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .