5

I have a strange behaviour with an USB keyoboard connected to a MacBook Pro laptop. Mac OS X version: macOS Sierra 10.12.2 (16C67)

In the laptop the keys are correct, but with the external keyboard the \| keys is inverted with the <> key

How can I solve this issue? hanks.

6
  • I think this question has been answer earlier in these forums, but I can't find it. My recollection is that Karabiner can fix the problem. Dec 22, 2016 at 15:57
  • No problem, my friend! The point is that is not simple to find similar question typing the symbols "\" or "<"... If you manage to find the answer tell me! Dec 22, 2016 at 16:56
  • Do you have Karabiner Elements already installed by chance? Dec 22, 2016 at 20:05
  • Bear in mind that people with English layout keyboards with the same basic problem will be asking about different keys, such as backtick/grave. You are using Spanish ISO, right? Dec 22, 2016 at 20:06
  • @TomGewecke Unfortunately I can't install Karabiner because, as reported in the official site, "macOS Sierra support status - Karabiner does not work on macOS Sierra at the moment." I'm using the Italian keyboard. Dec 23, 2016 at 8:34

1 Answer 1

14

This can be caused when the OS mis-identifies the keyboard. To get that back, clear the preference that saves which device is which layout.

How to reset the mac keyboard

I made as described in the post:

  1. Delete the file /Library/Preferences/com.apple.keyboardtype.plist
  2. Disconnect the keyboard
  3. Reconnect the keyboard
  4. Restart the os

After doing these steps, the keyboard had to be recognized again, and it fixes the issue.

The correct keyboard for Italian is ISO (Eur).

7
  • Very interesting! Normally I would expect a problem with that .plist to affect both internal and external keyboards. Dec 23, 2016 at 15:08
  • Had this issue on my Hackintosh, with a Corsair K70 LUX RGB mechanical keyboard using ckb-next as driver. This worked, thanks!
    – Manchineel
    Jan 15, 2019 at 21:29
  • 2
    This helped me to solve the same problem on a late 2011 Mac Book Pro and an external logitech k120 italian keyboard. Thank you a lot. Vabbè... visto il nome.... grazie mille Alessandro.
    – Patrizio
    Mar 3, 2019 at 14:03
  • 1
    @Patrizio Figurati! :) Mar 4, 2019 at 10:14
  • This worked for me, I had the exact same issue but with a Spanish keyboard. However the order of the steps I needed was delete file, restart, disconnect, reconnect.
    – Konamiman
    Jul 14, 2020 at 12:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .