5

I have a wireless USB drive that I sometimes need to connect to, but most of the time it is disabled. When I turn it on and try to connect my iPhone to it, it won't even show up in the list of available networks because my neighborhood has so many (dozens) access points! iOS seems to list a maximum of 6 at any one time.

There appears to be no way to completely ignore certain networks and force iOS to skip past them, and also no way to "whitelist" certain networks so that they always appear in the list of available networks. I know I can choose "Other" and manually connect to it every time, but I have a very long, strong password and typing it in every time on the phone is a huge pain.

Is there any way to make my iPhone find this network when it is turned on? It does show up occasionally, but it's basically dumb luck.

  • I don't think iOS has a limit of 6 listings at one time. Sometimes the list of WiFi networks on my phone is well over a dozen. – I0_ol Dec 22 '16 at 2:06
  • 1
    Hmmm interesting, mine has never, ever, shown more than 6 that I have seen, despite my Mac showing tons more. Same issue on my iPads... they never show all the surrounding networks so most of them cannot be chosen. Not sure if it's based on signal strength or what. – JVC Dec 22 '16 at 2:08
  • That is strange. Sometimes mine even shows networks with a very low signal. I can't usually join them but it still shows them. – I0_ol Dec 22 '16 at 2:22
  • So when you go to Settings > Wifi and the "Choose A Network" section populates, how many networks do you see? I never see more than 6 and then "Other..." – JVC Dec 22 '16 at 4:13
  • 1
    Holy crap @Tetsujin's comment appears to have done the trick!! Make that an answer and I will mark it as accepted unless I see a behavior change today. Thanks!!! – JVC Dec 22 '16 at 15:46
3

This is an incredibly obnoxious bug in iOS (and macOS) wifi network selection: basically the neighboring networks, which you have no interest in, fill up the wifi list so you don't see your own network which you actually want to connect to!

I've seen many unhelpful non-solutions to this problem such as "turn off automatic connection" or "change the wifi network priority list" or "reset your network preferences" or etc.. None of these "solutions" fixes the root problem which is that the iPhone simply doesn't display all of the networks and frequently picks the wrong ones to display.

Because Apple's wifi control panel on iOS (and the wifi menu on macOS) truncates the list of available wifi networks to a small list, it means that if there are dozens of networks in the area it is basically a crap shoot as to whether your desired network will show up. The noise drowns out the signal. You can't make the list longer. You can't blacklist networks you never want to see. You can't adjust it to "show all" or "show my preferred networks at the top of the list" or some other (currently nonexistent) setting in order to actually see your network. Instead you just have to keep refreshing and hope it shows up. This is a serious and annoying bug that Apple needs to fix, because there really is no consistent and reliable workaround as of iOS 12.1 at least.

| improve this answer | |
  • I couldn’t agree more. And quite frankly as far as I’m concerned, this is actually the answer to the question so I am going to except it. – JVC Nov 27 '18 at 22:22
4

If you can see the connection OK from your Mac, then try elevating its priority - which you can't do from the phone, but is simple on the Mac.

System Prefs > Network > WiFi > Advanced...

You can drag access points into a preferred order. If you move your WiFi to the top of the list, this should then sync to your iPhone & it ought to then choose that as its preferred connection.

| improve this answer | |
  • So far this is the closest to a solution, I'd call it like 90%. My wireless drive does now tend to show up on my iPhone, though it's not 100% of the time. For example right now the entire list of available networks is... 1) neighbor's network 2) another neighbor network 3) one of my access points 4) another of my access points 5) another of my access points 6) xfinitywifi. Occasionally one of the neighbor networks will disappear, and then my wireless drive shows up in the #6 spot. But when any other network appears again above it, then it drops because the list only holds 6. – JVC Dec 22 '16 at 16:06
  • idk why you can only ever see 6. I can see at least a dozen from my living room facing the street. I have a similar setup with my DSLR camera, switch its wifi on to drive it from the phone & within a few seconds it jumps to the top of the list, even though it's still currently connected to my regular home wifi - though it has a higher priority it won't jump to it automatically, I need to switch manually. – Tetsujin Dec 22 '16 at 16:13
  • BAH that's so weird... I'm on an iPhone SE running iOS10, what kind of phone are you on? Wish I could figure out why my phone never shows more than 6 networks! – JVC Dec 22 '16 at 16:14
  • 6S, 10.1 but I'm pretty sure it was the same on my older 5S – Tetsujin Dec 22 '16 at 16:17
  • 1
    I'm accepting this as the answer because it's by far the only thing that has come close. My desired network still disappears from my list occasionally, but I notice that my list will now expand to 7 networks much of the time, and my target network is always the last in the list when it's available, which is probably 90% to 95% of the time at this point. FAR better than before, so thanks!! – JVC Dec 22 '16 at 16:31
1

Have you tried disabling the Ask to join networks function?

To do this:

  • Go to Settings
  • Tap on Wi-Fi
  • Toggle the Ask to Join Networks option off
  • Exit Settings
  • Connect to your USB drive (you may need to do this manually)

Hopefully you should find that in future your USB drive will appear as a known network, while all the other neighbourhood ones won't.

| improve this answer | |
  • That feature is already disabled., but this isn't the issue unfortunately, I'm not being asked to join a network, it's a case where the network I want won't even show up in the list consistently because there are too many other networks and the list only goes 6 or 7 deep. – JVC Dec 22 '16 at 0:28
  • Oh, I see. And the neighbourhood networks are not ones you're using (or have used previously), they're just overpopulating the list because there's so many of them? – Monomeeth Dec 22 '16 at 0:32
  • Exactly. There's dozens of them in the surrounding area and there seems to be no way to see them all on iOS as there is on MacOS. – JVC Dec 22 '16 at 1:18
0

I found it lists WiFi in lexical order.

Here is a trick

  • rename you WiFi SSID to start from A (or some symbol maybe?)
| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .