0

Every time I type in a quote mark ("), the "smart" Chinese input method would automatically convert it to or for me. But compilers and interpreters don't know what “” mean, they can only recognize ".

How can I disable this conversion?

  • @Panda I've tried TextEdit(GUI) and vim(CLI). Both of them have done such conversion. – nalzok Dec 21 '16 at 14:00
1

In most Cocoa-based applications, you can disable this by unchecking Edit > Substitutions > Smart Quotes.

enter image description here

  • Not sure why, but it doesn't seem to work for Chinese input – Panda Dec 21 '16 at 15:31
0

In TextEdit, try invoking caps lock before typing quotes.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .