I don't ever want to be switched between spaces except when I request it explicitly.

In Yosemite, this could be solved by:

  1. disabling "Group windows by application" in Preferences -> Mission Control
  2. typing defaults write com.apple.Dock workspaces-auto-swoosh -bool NO in the terminal.

Together, these prevented all involuntary Space changes.

However, these measures don't seem to work in Sierra.

Clicking in the Dock takes me to another Space if there are any windows for the application on another Space. I don't want this to happen.

How can I change it so that clicking in the Dock cannot move me to a different Space?

note: I've checked ~/Library/Preferences/com.apple.dock.plist -- the value of workspaces-auto-swoosh is NO.

  • 1
    Thanks for such valuable hints how to disable auto swoosh in Yosemite. Unfortunately clicking on the iTunes icon in the Dock still takes me to another space :( macOS 10.14.2 (18C54). Do you know how to fix this?
    – Dmitry
    Commented Dec 21, 2018 at 7:08
  • Also it would be nice to see desktops content on the top of the screen by default in Mission Control. Is it possible?
    – Dmitry
    Commented Dec 21, 2018 at 7:09
  • I found an interesting option for iTunes: Dock - iTunes - Options - Assign To - All Desktops. Then it works correctly with closed iTunes window. Open window will be visible everywhere. Unfortunately Assign To - None works like Assigned To the desktop where iTunes was initially launched :(
    – Dmitry
    Commented Dec 21, 2018 at 7:24

3 Answers 3


I have macOS Sierra 10.12.6, and this option is in Mission Control settings (also looks like it's in the same place on my old Mac running 10.7.5). Simply uncheck the option "When switching to an application, switch to a Space with open windows for the application", and Cmd-Tab will no longer make you switch Spaces.

Clicking on an app icon in the Dock will also no longer switch spaces, unless the app is already selected (its name is in the menubar), in which case further clicks on the icon will cycle you through any Spaces with a window open for that app. Not 100% what you are asking for, but if the app is already selected you should have no reason to click the icon again anyway.

  • 2
    Here's an example use-case: I want to close Firefox and open the URL in a new Chrome window. In Yosemite I could do this: Copy URL, close Firefox, click Chrome in the Dock, (wait to make sure a new Chrome doesn't open), hit Ctrl-N, paste my URL. In Sierra: if I forget to check which window gets focus when Firefox closes, then I get yanked violently out of my current train of thought. I tend to open a lot of windows of each application, so if there's a more reliable way to open application windows without having to check which windows are already open and which have focus, I'd be delighted! Commented Sep 5, 2017 at 4:38
  • 11
    Yea, this isn't close enough for me. I don't want to be auto-swooshed EVER! I just went from El Cap to High Sierra and this is really, really disrupting my workflow.
    – Huliax
    Commented Apr 30, 2018 at 23:21
  • 4
    If you double-click on an icon in the dock, it will switch to that app's space, even with the option "When switching to an application, switch to a Space with open windows for the application" turned off.
    – Paul King
    Commented Jul 26, 2018 at 12:06
  • does not seem to work in Catalina :(
    – igor
    Commented May 24, 2020 at 13:57

Terminal solution for anyone wanting to automate it (e.g. when setting up a new mac).

defaults write -g AppleSpacesSwitchOnActivate -bool false

Equivalent to opening System Preferences > Mission Control and then toggling the When switching to an application, switch to a Space with open windows for the application checkbox.

Mission Control with the relevant setting highlited


This behavior is controlled by disabling a "gesture" in the mouse functionality. Go to System Preferences>Mouse>More Gestures and disable "Swipe between full-screen apps".

  • 3
    This is definitely not the behaviour asked by the OP ... Commented May 8, 2020 at 11:46
  • this is the right solution. The other answers with mission control doesn't work. You have to sort out your Trackpad/Mouse
    – ha9u63a7
    Commented Feb 3, 2021 at 22:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .