7

I am trying to install iTerm2 terminal emulator on macOS Sierra 10.12.1 using Homebrew.

I tried to download iTerm2 from its main site. However, the page is taking too long to respond. So, after searching the internet for alternates, I found and ran this command : brew cask install iterm2

I am new to MacOS and would appreciate if someone can help me out with this.

Here is the traceback:

kshitij10496@Kshitijs-MacBook-Pro  ~  brew cask install iterm2
==> Satisfying dependencies
complete
==> Downloading https://iterm2.com/downloads/stable/iTerm2-3_0_12.zip

curl: (28) Operation timed out after 300976 milliseconds with 0 out of 0 bytes received
Error: Download failed on Cask 'iterm2' with message: Download failed: https://iterm2.com/downloads/stable/iTerm2-3_0_12.zip
The incomplete download is cached at /Users/kshitij10496/Library/Caches/Homebrew/Cask/iterm2--3.0.12.zip.incomplete
Error: nothing to install
7

Homebrew had the same problem you had when you tried to download iTerm2 directly from its website - I imagine the website was temporarily offline (it seems to be OK now - I've just downloaded iTerm2 successfully).

I'd suggest trying again. If it still doesn't work, check the website on downforeveryoneorjustme.com, and wait until the website is back up.

  • Thanks for your answer. I agree that iterm2.com is up. However, the download site : iterm2.com/downloads/stable/iTerm2-3_0_12.zip is down. Is there any way I can work around this ? – Kshitij Saraogi Dec 19 '16 at 7:55
  • 2
    In that case, I think the problem may be at your end (or between you and iTerm.com) - I've just re-downloaded iTerm2 and it worked OK the second time as well. You could try checking with your ISP - mention that ordinary web browsing works OK, and that you checked on downforeveryoneorjustme.com and the site is up, but you still can't reach it. – John N Dec 19 '16 at 7:59
  • 1
    Thanks a lot for your advice. I changed my connection to a different ISP and it worked ! I find this a bit weird though. – Kshitij Saraogi Dec 19 '16 at 8:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .