35

Skype For Business 16.2.145 automatically starts and sign's in when my machine starts.

The usual solutions for Skype don't work for Skype for Business. I cannot change this setting in the dock or in the app's preferences.

How do I change this setting?

5
  • 3
    Have you checked system preferences - accounts - login items? Dec 19, 2016 at 1:08
  • 6
    @grgarside This is not a duplicate because I am referring to Skype for Business not Skype and that answer does not work for Skype For Business
    – TheLearner
    Dec 20, 2016 at 16:39
  • @RobdeJonge thanks mate. Your answer actually worked. If you set it as the answer I will mark it correct
    – TheLearner
    Dec 20, 2016 at 16:41
  • @TheLearner You just said it's not a duplicate, so I've re-opened your question, but now you say the login items solution works, which makes it a duplicate?
    – grg
    Dec 20, 2016 at 16:44
  • 1
    The answer in the duplicated question does not work. The answer that @RobdeJonge gave does work. If you look at the 2 answers they both different approaches to doing the same thing. Sadly only Rob's answer actually works. What do you want me to say mate?
    – TheLearner
    Dec 21, 2016 at 1:21

1 Answer 1

45

Check System Preferences - Accounts for Sierra, Users and Groups for Catalina - Login Items and make sure it's added there.

Alternative 1:

Open the context menu on the icon in the dock -> options -> uncheck "open at login".

Alternative 2:

Open the terminal and type launchctl list | grep skype.

Then use sudo launchctl remove <name from the previous output> to prevent it from starting at login.

9
  • 22
    This is correct, but to clarify for macos Sierra - if you don't want Skype for Business to open automatically go to System Preferences > Users & Groups > Current User > Login Items. If Skype for Business is listed, select it, and then click - to remove it. It won't start anymore.
    – dunxd
    Jan 28, 2017 at 0:18
  • 1
    Doesn't seem to work. Skype for Business is not listed there yet is still launches on login. Mar 15, 2017 at 13:01
  • 9
    So what I did was used terminal. Found it with launchctl list | grep skype. Then removed it with sudo launchctl remove com.skype.skype.shareagent.
    – Patrick
    Jul 31, 2017 at 13:36
  • 12
    Of all the applications that I've installed this year, why is it not surprising that only Skype thinks it's important enough to enjoy a unilateral login startup...
    – Owen
    Aug 3, 2017 at 5:49
  • 2
    @Patrick recent version uses upper Skype prefix so the command should be launchctl list | grep -i skype which means case insensitive search May 28, 2019 at 19:30

Not the answer you're looking for? Browse other questions tagged .