1

I have problems getting a Mac-Mini to connect to our QNAP NAS over Wifi. It once worked. As it's my wife's Mac and she doesn't care about backups or whatsoever, I don't know since when it actually doesn't work anymore.

Ping, nslookup and traceroute give no hints on network problems (ping comes back and so on). Tried telnet as well. It hangs on "Trying 192.168.1.3..." whereas telnet against other (LA)network devices gives "Unable to connect to remote host". As well tried QFinder (from QNAP) and it doesn't find the NAS.

We have three Macs at home (an iMac, the Mac-Mini and a MacBook Air, all with macOS 10.12.1). Internet and Routing is done via a Fritzbox 7490 (with FRITZ!OS 06.60). The iMac and MacBook Air have no problems connecting (via AFP or SMB) to the Shares on the NAS.

On the Mac-Mini when I CMD+K "afp://192.168.1.3/" (which is the IP of the NAS), I don't get the typical user-name-and-password dialog. There's just the small "Connecting to afp://192.168.1.3/" window which stays until the "There was a problem connecting to the server "192.168.1.3"" dialog is shown. In Finder the "Connect as..." button, shown under "Network"->"(AFP)", does nothing (But this is something I noticed on the other Macs as well).

Console shows:

11.12.16 12:13:21,778 NetAuthSysAgent[967]: AFP error -1 mapped to EIO
11.12.16 12:13:21,778 NetAuthSysAgent[967]: ERROR: AFP_GetServerInfo - connect failed 5
11.12.16 12:13:21,779 NetAuthSysAgent[967]: AFP error -1 mapped to EIO

I tried

  • removing Wifi-connections from Mac-Mini's preferences
  • restarting every hardware involved
  • sudo dscacheutil -flushcache (in Terminal)
  • Googleing and Duckduckgoing

Did anyone else experienced such behaviour? Does someone has ideas on what else to try, or even has a solution right away?

Thanks a lot in advance!

---- edit 2016-12-17 ---- I remembered, that I once had the same problem with the iMac, although with a slightly different network-setup. Back then I switched the iMac from manually assigned IP to DHCP - just because I was out of other options. This did the trick. As the Mac-Mini (having the problems now) is/was configured to use DHCP, I manually assigned an IP. Again, just because of not having any other ideas. And it woks!

I'm going to leave the question open, because it's not a real answer. The fact, that one time the problem is fixed by turning DHCP on, and the other by turning it off, confuses me.

Here some additional info on the network setup: Router/DNS: 192.168.1.1 Mask: 255.255.255.0 DHCP IP range: 200-250

In both described occasions the manually assigned IP was before/less than 200.

  • already tried mount_afp afp://name:password@server/folder /Volumes/folder? – klanomath Dec 17 '16 at 11:59
  • Just tried it. Hangs for one or two minutes and then fails with mount_afp: AFPMountURL returned error -1069, errno is -1069. Following this post this means "No servers". – dergab Dec 17 '16 at 12:37
  • Have you tried connecting via SMB (as opposed to AFP)? – NoahL Dec 17 '16 at 19:06
  • Yes. The NAS as a host doesn't seem to be visible for "higher" services/protocols than e.g. ping. – dergab Dec 17 '16 at 19:11
  • What happens if you issue the command mount -v -t afp user@server /Volumes/folder? – Allan Jan 1 '17 at 13:46

You must log in to answer this question.

Browse other questions tagged .