17

I've never turned on "sync documents and desktop to iCloud" but a friend says she never turned hers on but it's on. When she tries to turn it off, the "are you sure" popup says that it will keep the documents on iCloud but delete them from the Mac. That makes absolutely no sense!

But iCloud is full, so she can't save anything. Being a college student, that is a serious problem. And losing the documents, then having to log in to the web interface to get them back is equally ridiculous.

What is the easiest way to get the documents OFF of iCloud and keep them on the computer? She doesn't have another computer to make the sync worthwhile. She does have an iPhone but no one wants to write research papers on an iPhone. (Especially someone who depends on VoiceOver)

I know we could make a backup, and restore after the delete. Or re-downlonad from the web interface. But it's hard to believe Apple would make a process that user-hostile.

6
  • 1
    Actually, never underestimate Apple. Your best bet is to just make a backup of everything and restore it later. If you have Time Machine setup, you can already do it. Dec 17, 2016 at 5:29
  • 1
    Make a copy, let Apple delete the original, then put the copy back. Yeah, I told her I could do that, but that's just wrong.
    – WGroleau
    Dec 17, 2016 at 5:35
  • @WGroleau, if you do "make copies", you might want to make sure you do not end up with duplicates in the "iCloud Drive" folder as referenced in my answer below.
    – j-beda
    Dec 17, 2016 at 21:53
  • The files that appear to be stored in iCloud are actually stored locally, but in the synchronized folder somewhere in your ~/Library. When you stop syncing Documents and Desktop those folders in ~/ are emptied/removed but they remain in ~/Library/iCloud (or whatever) and are also visible on the iCloud drive (which mirrors ~/Library/iCloud) so what you do when you turn of sync and want to restore Desktop and Documents is that you just drag the contents of each folder in iCloud to their local counterpart in ~/. This moves the files from ~/Library/iCloud to…
    – d-b
    Jan 12, 2018 at 15:56
  • … ~/Desktop and ~/Documents. That is, even if the iCloud drive reports it is full nothing is lost because it is all stored locally and the transfer from ~Library/iCloud to ~/ is immediate. But Apple are lying, the contents of ~/Desktop has disappeared (it is in ~/Library/iCloud/Desktop) but it is not deleted when you disable the sync. This UI, error message and whole process are the worst I have seen in a looong while. And why the f*** would like you to sync your Desktop to the cloud. At least I use it for temporary storage of sometimes very big files (tens of GBs). And why would you…
    – d-b
    Jan 12, 2018 at 16:01

2 Answers 2

13

The wording of the warning is misleading. If you turn off this syncing, the files will not be gone or deleted, but they will not be on your ~/Desktop or in your ~/Documents folders. They will be in your "iCloud Drive" folder, which is a folder on your computer that is synced to iCloud, but is still available on your computer. To get things "back to normal" you will just have to move the files from the "iCloud Drive" folder back to the ~/Desktop and ~/Documents folders.

Here is how to clean things up:

First go to Apple menu -> "System Preferences" -> iCloud

In iCloud preferences you should click the "Options" button beside the item "iCloud Drive" and if the "Desktop & Documents Folders" item is selected, then that is probably what is causing you to be using so much space on Apple's computers. If you uncheck this box, you can recover a lot of space from your iCloud storage, but it will take a few more steps for it to be "back to normal":

Go to Apple Menu > System Preferences > iCloud > iCloud Drive > "Options" and UNcheck the "Desktop & Documents Folders" checkbox. You’ll get a pop-up warning you that these files will only be stored in iCloud Drive if you disable Desktop and Documents syncing. Go ahead and click “Turn Off”. Files on your desktop and in your Documents folder will seem to be removed but they are still within the "iCloud Drive" folder on your computer, which will automatically open after you click “Turn Off”, so these files aren’t actually disappearing and getting deleted, but are simply in iCloud Drive exclusively.

Next, open up the iCloud Drive folder on your Mac and you’ll see two folders called “Desktop” and “Documents”. If you cannot find the "iCloud Drive" folder (it is likely listed in a Finder window's "sidebar" which can be displayed using the Finder menu item "View" -> "Show Sidebar" if the sidebar is hidden), you can have access to it by going to the Finder menu item "Finder" -> "Preferences" -> "Sidebar" and making sure the "iCloud Drive" item is checked. Alternatively you can use the Finder menu item "Go" -> "iCloud Drive" to open this folder.

The folder "iCloud Drive" is where your files are. You can now move the contents of "iCloud Drive"/Desktop and "iCloud Drive"/Documents back to your ~/Desktop and your ~/Documents folders.

You can leave the now empty “Desktop” and “Documents” folders in "iCloud Drive". If you delete them, they might get recreated automagically, so don't be surprised.

The following website has some pictures of the windows as well as some of the text I copied above: http://www.howtogeek.com/273629/how-to-restore-your-desktop-and-documents-after-disabling-icloud-sync-in-macos-sierra/

Here is another reference about the issues: http://www.macworld.com/article/3098804/data-center-cloud/how-to-use-icloud-drive-s-new-desktop-and-documents-access-in-macos-sierra.html

0
0

I have tried all solutions like the accepted one and it did not work for me. This worked for me:

  1. Create a directory called, ~/myStuff
  2. Move ~/Documents and ~/Desktop into ~/myStuff.
  3. Turn iCloud off sharing for `Desktop and Documents.
  4. Login to https://www.icloud.com/ and delete Desktop and Documents from there. Do not forget to empty the recently deleted files there.
  5. Now that your Desktop and Download folders are empty, iCloud will have to make iCloud empty.
  6. Delete the local copy of Desktop and Downloads inside iCloud Drive on your Mac.
  7. Turn off sharing Desktop and Documents to iCloud.

This is the only way I have managed to stop that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .