1

I've enabled an NFS share using a tool on my MacBook Pro (aptly called NFS Manager), which has worked before. However I'm on a new network and when my mediaplayer is scanning for network drives it will not find the share. Manually entering the IP and folder does not give any results either.

How can I check whether the NFS server is running and what is blocking access?

1

You can check if the server is running in NFS Manager itself:

Hit the Test Server button in NFS Manager:

enter image description here

Enter the IP of the server (either 127.0.0.1 or the interface IP e.g. 192.168.0.5) and hit "Test".

enter image description here

If the NFS server is running you get the following result:

enter image description here

Some of the ports depend on your configuration. The above example shows the standard ports.

From remote you can check this by executing nmap. A running NFS server looks like this:

host:~ user$ nmap ip

Starting Nmap 7.30 ( https://nmap.org ) at 2016-12-16 01:26 CET
Nmap scan report for IP
Host is up (0.00015s latency).
Not shown: 967 closed ports, 27 filtered ports
PORT     STATE SERVICE
111/tcp  open  rpcbind
1001/tcp open  unknown
1021/tcp open  exp1
1023/tcp open  netvenuechat
2049/tcp open  nfs

If your firewall is off, then either your NFS server or client (or both) are configured incorrectly.

  • Thanks klanomath! I've tried and it says there are no NFS servers found. However I notice that the trial period is expired so does that mean that the tool is not functioning anymore? – LinkeLoutje Dec 16 '16 at 14:19
  • @LinkeLoutje I don't think there is a trial expiration (at least there wasn't one in the past). It always shows a nag screen though: A demo mode panel will appear each time you launch the application/you save changes in the NFS configuration. There are no other functional restrictions. You may have to add some screenshots (like my first screenshot and maybe a screenshot of the "Show Advanced Options..." window... – klanomath Dec 16 '16 at 14:51
  • Thanks! I noticed I made the error to browse and select my MacBook from the list instead of entering the IP. The tool shows that v2 and v4 NFS services are running. Now entering the question as to why my mediaplayer is not able to access them... – LinkeLoutje Dec 16 '16 at 15:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .