0

MacBook Pro Early 2015 OS 10.10.5 (because of Internet Recovery)

Problem: So for the last few days the built in trackpad and keyboard of my MacBook Pro have been acting up. After waking up from sleep, they were unresponsive, or didn't respond at all. After waiting some time, they worked again (until next sleep).

Resets: So in an attempt to fix it, I tried all the resets one get told to do (PRAM, NVRAM SMC), without any effect.

Reinstall: At some point, I wanted to make a clean install and booted in recovery mode. Here the internal keyboard and trackpad worked 100% of the time. That is until I erased the drive. Now only external input devices work at all (even in Recovery).

I even tried Internet Recovery so now I have a freshly installed Yosemite on a erased drive. The keyboard light is working and the trackpad clicks. But Yosemite doesn't detect them at all (Bluetooth Assistant starts since no keyboard/mouse is detected).

Can I somehow check if the driver(?) is installed correctly. Can I totally wipe my Laptop ( Drive, Recovery Partition UEFI)? And would that help?

Could it be a hardware error, even though it worked 100% at some point in Recovery Mode? At some point I noticed that the keys would work if i pressed them for a long time, but as of now this isn't the case.

  • 1
    This sounds like a hardware issue. The keyboard and trackpad, while related, are two distinct devices. Try running Apple Hardware Test (AHT). Hold the D key while booting from a powered off state with the AC adapter connected. Have you tried using an external mouse/keyboard? What about a wireless/bluetooth keyboard? If it works there, then it's not a software issue. Also, be sure to update your question with the specific model of your MBP – Allan Dec 15 '16 at 11:38
  • At this moment the internal keyboard & trackpad work, but I am unable to boot into AHT (or Network AHT). I tried it both with internal and an USB keyboard. Normal input with USB devices works all the time. – Maurice Schleußinger Dec 15 '16 at 12:43
  • 1
    Try with Bluetooth Your internal keyboard/trackpad are connected to the USB bus as are external wired mouse/keyboard. However, Bluetooth is connected directly to the PCIe bus. If things work there, you would have diagnosed the problem as potentially being related to the logic board. – Allan Dec 15 '16 at 12:59
0

To close this up:

I went to an Apple Store had the logic board replaced. Afterwards, I reinstalled from a backup and everything seemed fine...

But yesterday I noticed that I forgot to re-enable disk encryption (using File Vault). After enabling it and rebooting I got the exact same problem again. This time I also experienced the problem described here: Password incorrect after enabling FileVault

But unlike last time the problem disappeared (so far) after disabling encryption again.

If you wind up here looking for answers: Try disabling File Vault and check this for more details: MacBook startup problems - mouse and keyboard not working at login / stuck on apple logo

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .