20

I got the macOS Sierra update when it went into public beta, and I've been trying to use the automatic Desktop / Documents upload feature with iCloud Drive.

I've enabled the feature, however since September 7 no files have been uploaded. By this point, the bottom of my Finder windows say:

15.78 GB available on iCloud, uploading 156,106 items (543.2 MB of 543.2 MB)

However the files are never actually uploaded. I keep my screenshots folder on my desktop and I take a lot of screenshots, so I can see that September 7 was the last date any file was actually uploaded.

What should I do? Is there a way I can disable and re-enable the feature without risking loss of data? Are there any solutions to this problem? What should I try? So far I've tried rebooting, and tried software update to macOS 10.12.2 public beta.

5

Happened to me as well, here is what I did:

  1. Back up all items in the Documents and Desktop folders
  2. Open up System Preferences
  3. Click on iCloud
  4. Click on Options next to iCloud Drive
  5. If Desktop and Document Folders is disabled, enable it
  6. If it enabled, un-enable it.
  7. Uncheck the Optimize Mac Storage and click Done
  8. Redo the opposite of this to re-enable iCloud
  9. Move all Documents and Desktop items back to their respective area.

It is helpful to note if you are experiencing sync issues in any of the other categories in iCloud Drive, try disabling them and then re-enabling them.

| improve this answer | |
  • Since not all items are backed up won't this cause a loss in data? It displays a warning about how documents will be removed... – Luke Taylor Dec 15 '16 at 5:56
  • @LukeTaylor I don't think it should wipe anything from your local storage, and when you turn it back on, it will start the sync again, replacing all duplicated files. – Rushil Srivastava Dec 15 '16 at 22:45
  • 2
    Unchecking the box brings up a warning that "if you continue, items will be removed from the Desktop and Documents folder on this mac and will remain available in iCloud Drive". It's kind of ambiguous about how it will treat unsynced items. – Luke Taylor Dec 15 '16 at 22:49
  • @LukeTaylor, In finder, do you see the iCloudDrive on the top left? Click on it and let me know if your files are inside the documents and desktop folder – Rushil Srivastava Dec 16 '16 at 1:05
  • 1
    They are, but I haven't yet disabled the iCloud sync for these. Most of them have the ☁️ icon indicating that they haven't yet been uploaded. – Luke Taylor Dec 16 '16 at 1:19
1

Have you changed the date and time on your computer or phone? This is a possible explanation of why iCloud is not syncing.

| improve this answer | |
  • They're all correct. I rely on those times and dates daily, I'd know if they were off. – Luke Taylor Feb 13 '17 at 2:40
0

Be careful, this method will Delete the files. Managed to solve it by:

  1. Go to System Preferences
  2. Select iCloud
  3. Untick iCloud
  4. At the prompt select Remove from Mac
  5. At the next prompt select Stop Updating and turn off

Should be fixed, worked for me, really annoying

Second scenario that worked, on iPhone:

  1. Open Settings
  2. iCloud Drive
  3. Manage Storage
  4. Click on the folder that's at fault and remove it from iCloud
| improve this answer | |
0

You can try the following command from the console. It will recursively traverse your directory while updating the last modified date of each file. It will do this for all files but "*.icloud". The command will also print the name of each updated file.

go to the iCloud directory,

cd /Users/admin/Library/Mobile\ Documents/com~apple~CloudDocs

Please: double check that you are in the directory above. Use pwd

and trigger the date update for those files

find . ! -path "*.icloud" \( -exec echo {} \; -a -exec touch {} \; \)
| improve this answer | |
  • Can you please explain what exactly this command does? – pkamb Dec 25 '19 at 23:03
  • yep, the answer is updated. – user9869932 Dec 27 '19 at 13:10
0

Further to user9869932 above about resetting the date.

Note it should be cd "/Users/-your user name-/Library/Mobile Documents/com~apple~CloudDocs"

then doing the command find . ! -path "*.icloud" ( -exec echo {} \; -a -exec touch {} \; )

Will give you a massive list - in my case - of files it resets the date on that are waiting to upload. The files then begin to upload. Check this by double-clicking on the little Pie icon in the Finder window. This brings up the progress bar. Your files will go up in batches, determined by whatever throttling Apple has set for the process. Mine went from over 4000 items to 1,175 in a few minutes but now seems stuck again.

Now I notice that the list of update files includes files in Trash and other places where the files no longer exist. So I'm suspecting that the iCloud sync process is not handling this well. Deleted and moved files are hanging about in the 'com~apple~CloudDocs' folder even when removed from their original locations. So now instead of having just a few files not uploaded, I seem to have 1,175 items waiting to upload - which probably never will.

| improve this answer | |
0

do not forget that osx is based on unix. what helped me is changing of 'bird' process priority ('bird' process is responsible for icloud replication).

  1. enter image description hereenter image description here

double click on 'icloud' icon in finder to see progress.

  1. go to terminal

    3.

ps aux |grep bird You will see your bird process id, in my case it is 815.
serg 815 98.8 0.8 4542828 137776 ?? U Thu09PM 2047:53.94 /System/Library/PrivateFrameworks/CloudDocsDaemon.framework/Versions/A/Support/bird

4.

check current priority of bird process ps -fl -C 815 (replace 815 on your bird process id from step 3) if you never changed it before, it will be zero (under NI column, but formatting of output is not nice)

5.

change priority (negative numbers are high priority, based on research -20 is the highest, but do not put it, i suggest to put -10) to do it

sudo renice -n -10 -p 815 (again replace 815 on your bird process id from step 3) it will ask for password if you are not root currently in terminal

6.

if it worked, you should see progress in the icloud progress dialog you opened on step 1 Cannot guarantee it will work always, as icloud is blackbox.. unfortunately .. i.e. mac has unix core, but all above it is blackbox proprietary software

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .