0

Whenever I bring my 2015 Macbook Pro to a certain corporate environment and try to use WiFi there, it is painfully slow. At times, Google takes 5-10 seconds to load. Now, a Windows machine works just fine on this same network. What is more, when another person tries to use his 2016 Macbook Pro, he encounters the same problem.

Does anyone know what settings or configurations we can check either on the Macs or the network to fix this?

Any advice is appreciated.

1

Try this setting, it helped me in the same situation :) In the network settings change the address of DNS servers to Google's ones: 8.8.8.8 or 8.8.4.4

For this go to Settings > Network > Advanced... > DNS > press + and enter DNS address.

enter image description here

Or, vice versa, you may ask your system administrator for any specific DNS and probably proxy settings that your company might have due to security reasons and then enter them in the Proxy tab.

enter image description here

7
  • Just to clarify, did this solve the issue only for the Google site or for all of them? I used Google as an example, but other sites are phenomenally slow as well. – MadPhysicist Dec 14 '16 at 19:37
  • 1
    For all of them, of course. – Denis Rasulev Dec 14 '16 at 19:38
  • Thanks! It made it much faster, albeit there is still a delay of about a second, which is due to WiFi, I guess. – MadPhysicist Dec 14 '16 at 19:43
  • 1
    Glad to hear. If you think this has solved your problem to your satisfaction, then you may consider accepting my answer :) – Denis Rasulev Dec 14 '16 at 19:46
  • 1
    I did. However, I am still open to hear other ideas :-) – MadPhysicist Dec 14 '16 at 19:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .