16

Since updating to Max OS 10.11.6 this morning I've seen this message several times. It's a bit weird as I never use Safari. I suspect it might be something to do with the AppStore trying to update. Any ideas on how I can stop this?

From the report that this generates it's clear that Spotlight is the culprit (thanks Dmitri for pointing this out)

Process:               com.apple.Safari.History [4881]
Path:                  /System/Library/PrivateFrameworks/SafariShared.framework/Versions/A/XPCServices/com.apple.Safari.History.xpc/Contents/MacOS/com.apple.Safari.History
Identifier:            com.apple.Safari.History
Version:               11601 (11601.7.1)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Spotlight [464]
User ID:               501
  • same here - it's since the update. – Toby Dec 15 '16 at 0:18
  • I've also been seeing it a lot in El Capitan for a while, but most likely because I've been running the Safari betas there. – calum_b Dec 15 '16 at 17:39
  • btw. I'm now seeing the same crash when using the app store... – Toby Dec 15 '16 at 20:19
  • FYI -- this is still a bug with Safari 10.0.3. I've turned off the Bookmark & History checkbox, but it still comes back... – SMGreenfield Jan 7 '17 at 4:24
  • This finally seems to have been resolved by the Safari 10.0.3 update from 2017-01-24. Handily, along with the 10.11.6 update from 2017-01-19 there was no change in the version numbers. Thanks, Apple! :-( – Charlie Clark Jan 25 '17 at 14:49
3

It's because of Spotlight. Whenever you do a Spotlight search, apparently some Safari history search framework is loaded in the background, and this now crashes because some symbol was not found:

Dyld Error Message:
  Symbol not found: _initializeSandbox
  Referenced from: /System/Library/PrivateFrameworks/SafariShared.framework/Versions/A/XPCServices/com.apple.Safari.History.xpc/Contents/MacOS/com.apple.Safari.History
  Expected in: /System/Library/StagedFrameworks/Safari/SafariShared.framework/Versions/A/SafariShared

This is a bit of a bummer, it makes Spotlight mostly unusable.

P.S. 2016-12-16: I had reported the bug to Apple, and they have now closed it as a duplicate, so they have at least received multiple identical reports. Let's hope it gets fixed soon.

P.S. 2017-01-24: Safari 10.0.3 has been released as a security update (see https://support.apple.com/en-us/HT207484), but it also resolves this particular crash, at least for me. It would be nice if somebody else can also confirm that.

5

Folks, I have a workaround doing ok on an iMac 5k with 10.11.6 with the latest update and the same error.

I open System Preferences - Spotlight and un-check "Bookmark & History". Then quit Safari. Again open System Preferences - Spotlight and check "Bookmark & History". Try a spotlight search. For me it worked. I also could start Safari again and the error does not come back.

BUT the error is back after restart, maybe also after hibernating (did not test yet).

Maybe the workaround works for you as well until there is a fix.

By the way, letting spotlight create a whole new index did not help, so likely you can spare that try.

Cheers Sepp

  • Good idea. Of course, you can just leave the preference unchecked if you don't have any need to see bookmarks and browser history in your search results, which I don't... then it should still work after a restart. – calum_b Dec 15 '16 at 20:33
  • And what if I never use Safari? – Charlie Clark Dec 16 '16 at 10:17
  • This is absolutely unhelpful, sorry – Teejay Jan 15 '17 at 23:43
1

Happens while using spotlight (bing/bookmarks&history DISABLED) and app store:

Process:               com.apple.Safari.History [39915]
Path:                  /System/Library/PrivateFrameworks/SafariShared.framework/Versions/A/XPCServices/com.apple.Safari.History.xpc/Contents/MacOS/com.apple.Safari.History
Identifier:            com.apple.Safari.History
Version:               11601 (11601.7.1)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Spotlight [369]
User ID:               501

Date/Time:             2016-12-15 21:20:52.717 +0100
OS Version:            Mac OS X 10.11.6 (15G1212)
Report Version:        11
Anonymous UUID:        7D4DD151-6750-1098-7D7A-8971F372E9F0

Sleep/Wake UUID:       0BD4AC71-496A-489B-9C0F-01438C9108F3

Time Awake Since Boot: 22000 seconds
Time Since Wake:       480 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000002, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Dyld Error Message:
  Symbol not found: _initializeSandbox
  Referenced from: /System/Library/PrivateFrameworks/SafariShared.framework/Versions/A/XPCServices/com.apple.Safari.History.xpc/Contents/MacOS/com.apple.Safari.History
  Expected in: /System/Library/StagedFrameworks/Safari/SafariShared.framework/Versions/A/SafariShared
  • Yes, it looks like other apps are using the private API. ITunes and the AppStore do use Safari/Webkit internally — their needs were one of the drivers for Apple to improve Webkit back when they cared. – Charlie Clark Dec 16 '16 at 10:18
  • 1
    it's interesting that this is literally the only matching result on google so far... I get the message 3 times in a row when starting safari and every time I use spotlight or app store. it's pretty annoying... I might have to switch to alfred if that continues but then alfred might be affected too. – Toby Dec 16 '16 at 10:19
  • It's obviously deep within the system. Apple's QA fails again. Maybe if we flood them with the error reports they'll get round to fixing it but I wouldn't expect anything before the end of January. – Charlie Clark Dec 16 '16 at 10:22
  • haha, someone needs to make a selenium script that keeps triggering the error report and sending it over and over and over... – Toby Dec 16 '16 at 10:23
  • just want to add that I got so annoyed by it I upgraded to Sierra and it's fixed there... safari still has random freezes but that just seems a standard safari thing that it even does after deactivating all extensions. – Toby Jan 13 '17 at 17:02
0

I did a restore from my time-machine and the problem seems to be gone for now. System/Library/PrivateFrameworks/Safari.framework I have no clue and don't care if my security is now at peril danger.

You must log in to answer this question.

protected by Community Dec 16 '16 at 21:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .