2

I'm having trouble shutting down my MBP early 2015 model(MF839) with retina display. Sierra had been working smooth for almost 2 months and now I'm getting this issue.

Once I shut down, the screen goes black with just my mouse pointer visible on screen and stays like that forever until I long press the power button to force shut down.

  • I had faced similar issue when I installed Sierra OS, and that time it was due to MySql incompatibility. Solved it by reinstalling MySql.
  • I'm sure some process is blocking my mac to shut down correctly.
  • Tried sudo shutdown -h now and it works.
  • I've tried turning off the FileVault and reinstalling MySql, but didn't help.
  • I've tried resetting PRAM and SMC. I've tried reinstalling Mac OS(in recovery mode keeping all the applications and data intact).
  • I couldn't point out any processes causing this issue from Activity Monitor or from the Console logs. Tried searching for the shutdown-log file and could n't find it.

Only option left for me is to take it to service center and they will just format and reinstall my mac(I would loose all my data and have to reinstall every single app once again).

Any thoughts on this?

Thanks, Sudheesh CM

  • What happens when you startup in Safe Mode and then try shutting down? To start in Safe Mode, hold the Shift key down while your computer is booting up. – Monomeeth Dec 14 '16 at 21:44
  • I'm currently having the exact issue verbatim with a nearly $4k late 2013 i7 Intel 16GB RAM w/ separate graphics card, SSD HDD, blah, blah, bells & whistles, maxed out Retina Pro that I was told that I "...would never have any issues with..." and should last me "...anywhere from 5-7 years" 😡 My WiFi doesn't work (appears to be the card that's the issue! I love my Apple products (all 7 of them!), but if I'm gonna pay good $$ for the "higher-end", I expect it to last and work longer/better. Any new info/updates/etc.? Any help would be appreciative, thanx! – Steve G Dec 28 '16 at 4:28
  • I haven't tried this for a while, but verbose mode used to show more information during shutdown (and startup) which might give some clues. – Ashley Feb 27 '17 at 16:24
2

The solution I have found after long suffering this problem in High Sierra after trying to upgrade from version 10.13.5 to 10.13.6. I deleted these files through terminal, then rebooted.

You may need to run with admin permissions, i.e. "sudo rm -f etc." and enter your admin password when asked:

rm -f /Library/Preferences/com.apple.loginwindow.plist

rm -f /private/var/db/.AppleUpgrade

rm -f /private/var/db/.SoftwareUpdateAtLogout

reboot
1

I am having similar issue. Do you happen to connect to remote shared drive through Samba (SMB)? If that's the case, check following link: https://discussions.apple.com/thread/7411011?start=0&tstart=0. There is actually no solution (wait for Apple to fix this), but to turn off SMB on remote server (MacMini) and stick with AFP.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .