1

I've been struggling with this peculiar problem for over a week now. It appears when I have the FileVault enabled and it behaves like this: when booting the laptop it takes 2 or 3 minutes until it gets to the login screen and once it gets there I can't type anything and can barely move the cursor.

My current configuration is: 13-inch rMBP w/ macOS Sierra, 8GB RAM and somewhere around 30% available disk space. I've tried a PRAM/SMC reset but no lock. Also the diagnostics tool didn't return any error and in the recovery mode I couldn't find any disk errors to fix (before and after disabling FileVault). Even if I boot in Safe Mode successfully, after restarting it gets into the same issue again.

I've tried tailing the system log, disabling useless .plist files and launch daemons that could've influenced the boot time. I've also tried unplugging all my peripherals and it's the same situation. However, with the FileVault disabled it doesn't get stuck in the login screen, but it still needs 1 minute to boot.

I know about a similar issue with the MySQL daemon on Sierra, but it's not my case... I don't have any database installed locally. The single thing would be several homebrew packages that I don't see how they could influence the boot time. I've been pretty desperate with this issue and been trying to avoid starting from scratch with a clean install, because that would imply a lot of configuration.

One thing that I remember is that on El Capitan I didn't have this issue at all or anything related to startup and the boot time was generally of several seconds. Is there any solution or at least a method to give me a hint what's taking so long to boot my machine? Any help will be much appreciated.

  • I have a similar problem: see apple.stackexchange.com/questions/261369/… – BMM Dec 28 '16 at 17:06
  • @BMM I turned FileVault on and after off and it worked, for me the SD card reader wasn't the issue, sorry. – Cristian F. Dec 28 '16 at 17:10
  • I've seen this, too. Using an external keyboard and mouse at the EFI Login Window work in my experience then the built in ones work just fine after starting up. Be sure to report this to Apple if you have any support options available. Even after disabling FileVault it still takes that long to boot? That part is peculiar... – MacManager Jan 9 '17 at 21:40
  • @MacMamager turning off FileVault fixed this. I will turn on FileVault again to see if it happens again. – Cristian F. Jan 10 '17 at 6:56
1

I have had this exact problem.

I have a 2015 13" MBP running Yosemite (Mac OS X 10.10.5), not Sierra, though I have 8gb RAM and about 20% free space on an aftermarket 500gb SSD (e.g. not Apple factory installed). I use the laptop constantly and travel a lot with it. I've run into this bizarre boot/lag problem with FileVault roughly 2x-3x a year, and as luck would have it, it usually happens when I don't have access to any hands-on tech support besides myself.

The only thing that works for me:

  1. Disable FileVault: boot into Recovery Mode (command-R after startup chime) or if you have another boot partition. I have a TechTool Pro (TTP) emergency boot partition. Run Apple's Disk Utility from that boot partition and use the "Turn Off Encryption" command.
  2. Reset the SMC: shut down computer; hold shift-control-option-power for at least 10 seconds; start up computer.
  3. Once decrypted, run disk utilities on that drive. Besides Apple's Disk Utility for disk and permissions repair, I use TTP's "Volume Rebuild" tool (once I've booted from the emergency partition).
  4. Use the drive for a few days un-encrypted, with several clean reboots.
  5. Boot back into Recovery or emergency partition and run all those utilities again.
  6. Turn FileVault back on.

This typically works for me. However, it's annoying and time-consuming to resolve. And this is a repair, not a fix. It will still happen again, randomly, sometime in the future.

The fact that you have this problem on Sierra (Mac OS X 10.12) suggests to me that the problem is deeper than just the OS.

  • I now have that Problem too with a 2018 MBP and 10.13.6. Does anyone have a better solution? I think that only ONE of these steps is necessary and not all – gutenmorgenuhu Jul 25 '18 at 8:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .