2

I use a late 2013 macbook pro 13 inch retina display.

I tried formatting my internal ssd hard drive (macintosh HD) after it started freezing forever whenever I tried to log in. I tried all the workarounds but nothing helped. I couldn't re-install the os on the internal hard drive because of an incomplete file vault encryption that was stuck at 'paused. ' I therefore decided to erase my internal hard drive but I formatted it as an MBR instead of Guid Partition Map by mistake. Now my macbook can't read my internal ssd drive at all. It doesn't appear in disk utility and I can't install a new os on it as it doesn't appear when I run an installer from an external thumb drive.

I managed to install and run the os Sierra from an external hard drive but after I log in I immediately get the 'Macintosh HD not ejected properly' message.' When I run disk utility again it only recognises the external hard drive Im using to run the os. Macintosh HD doesn't appear at all.

I don't think it's a hardware issue because the internal macintosh HD was working fine before I tried to format it. By fine I mean I was able to access my files in safe mode and make a time machine backup.

How can I fix my internal ssd macintosh hard drive? Unfortunately we don't have an istore or authorised service providers in my country (Botswana).

  • Does recovery mode(holding cmd-r at boot) work?(without any USB) – abc Dec 13 '16 at 1:55
  • Unfortunately no. It takes almost the whole day downloading the os then gives an error message saying I must seek help from apple website – Loruo Josiah Dec 13 '16 at 2:07
  • You can enter recovery mode though, but you can't reinstall the OS from there, right? – abc Dec 13 '16 at 2:12
  • That is correct. The globe just spins for hours on end then gives me an error directing me to apple website. – Loruo Josiah Dec 13 '16 at 2:30
  • Can you please put an image? – abc Dec 13 '16 at 2:37

You must log in to answer this question.

Browse other questions tagged .