4

I have a problem with my iPhone 6. My iPhone 6 bootloops similar to this question: Why would my iPhone 6 be stuck in a dead battery loop?

However, the answers there do not help. In addition, when I try to restore my iPhone, I get an Error 9. I have not tried a new USB cable, but I want to check if that is it before I buy a new one.

I have tightened the battery and Lightning port connections, and this phone was never dropped in water.

  • You also tried another USB port? Are you using a Mac or PC? – LH16 Dec 15 '16 at 10:55
  • Provide more detail: iOS version, what you tried in iTunes (restore or custom update), stage it failed at, how this issue began... – Jack of all Spades Dec 15 '16 at 21:57
  • @JackofallSpades IDK, both, it fails right when it prepares to load the software onto the phone/ – QuyNguyen2013 Dec 16 '16 at 2:57
  • You need a new cable. See my answer, hope it helps. – owlswipe Dec 16 '16 at 18:49
  • Hey there, I'd love it if you either accept my answer or leave a comment to tell me what's wrong with it! Let me know if using another cable works and if it doesn't I would be happy to keep helping out :D. – owlswipe Dec 22 '16 at 2:01
4
+50

iFixit has a solution to your problem.

The iPad in my experience is very picky about what cables it will restore with. Error 9 is almost always related to the cable, NOT the dock connector/flex cable. Use the official Apple cable if you still have it, or borrow one from a friend.

tl;dr: It's the cable's fault, plug your iPhone into iTunes and update your software again with a different cable.

This has happened to me before. Trying to update software on an old iPod Touch by connecting it to iTunes with a non-MFi cable, got an error message and a crash. Replacing the cable with a genuine Apple one fixed my issue.

If you're looking for a cheap, MFi-certified cable, try this $6 one from Anker. Or get the official $19 one.

0

The error 9 mostly caused by the faulty cable/port. As Owlswipe said, the first thing is to change a new USB cable and try again. Then ensure the connection between iPhone and computer is normal. Note that you might need to install the latest version of iTunes and close all virtualization apps to ensure the well-off access of Apple Servers. BTW, if your phone has jailbroken before, it might be the reason for the error 9.

Another way you can try is restoring your phone in recovery mode/DFU mode. Both methods can help you force restore your iPhone but the later one can eliminate the software issue, you can get more details in the how to fix iPhone stuck in boot loop article.

0

you can google iphone error 9 to find a solution to fix it. I have face the same problem before. Method 1. RecoveryTool Fix Recovery can fix it successfully. Method 2. Open iTunes, connect the phone and put it to the DFU mode ( press home and power button together, when the screen goes dark release the power button, but keep pressing the home button, until you hear the sound of the computer recognizing USB device) and then restored it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .