My iPhone 5's Calendar shows the year as 2559 BE and I'm unable to change that to the current year.


Your phone doesn't actually have the wrong year. It looks like your phone is set to use a Buddhist calendar for some reason. To change it to Gregorian:

Go to Settings > Language & Region > Calendar > Gregorian.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .