3

Whenever I open a .pdf (haven't tried with other formats) with many pages (at least > 5), Preview does this really annoying thing:

I use the Rectangular Selection tool to select an area of the .pdf I want to copy. rectangular selection area

When I copy, the page does this: upon command+c, this happens (only for .pdfs that are many pages/large size)

When I click the area off, then I can see the page again. as soon as I click again, it goes back to normal...

Because I tend to make flashcards/store several selections of what I copied with the Rectangular Selection, I'd like to know what I can do to solve this issue.

Some useful information: I'm using macOS Sierra beta. I understand that this means I'll probably encounter more bugs than someone that isn't using the beta, but before installing a Release Candidate, I figured I could learn some stuff. I've tried deleting the .plists for Preview with no luck. When I zoom into the page (after pressing ⌘c and the weirdness happening), the page probably re-renders and the problem goes away. If I press ⌘c while zoomed in, the weirdness ensues.

Any advice on how to reinstall/format the app before that doesn't require a new installation would be much appreciated!

  • 2
    There's probably no reason to reinstall the OS. If you can reproduce this issue with the same document on a new user account, maybe file a bug report with Apple - openradar.appspot.com has some details on filing bugs. – bmike Dec 11 '16 at 23:32
  • 1
    Sierra is already on 10.12.1 Try that first. – LexS Dec 12 '16 at 12:15

You must log in to answer this question.

Browse other questions tagged .