20

Capturing screenshots on the Mac has gotten very slow recently.

It used to be nearly instantaneous but now it is taking more than 10 seconds for the image to appear on the desktop.

I seem to recall having this problem years ago. The workaround was to delete a large accumulation of log files that the os had built up. After I deleted these log files, the screen capture worked very fast again.

Problem is that I cannot remember where these log files are. Searched for quite some time and could not find the information.

10

I had the same problem. In my case, I stopped the Google Backup & Sync program and then the screenshots were captured quickly again. Try quitting Google Backup & Sync.

  • 1
    I have NO idea why this worked, but it did. I only allow GoogleDrive to sync certain directories and the Desktop is not one of them... but when I quit the Google Drive sync app then my screenshots make nigh instantaneous again. – Kenny Wyland Dec 12 '17 at 22:13
  • I've had the same problem a month or so ago, then it went away, then it came back last week. Disabling Google Backup & Sync worked for me as well. Not sure what that does actually, though :P Drive seems unaffected, but Idk. – Mattia Jan 3 '18 at 20:02
  • 1
    Is there a workaround for this? It would be a pain for me to not have Google Drive sync automatically. – tyteen4a03 Feb 27 '18 at 10:09
14

On High Sierra I faced the same problem, which had Google Backup & Sync as reason of failure (as Robert answered before). Instead of completely quitting Google Drive & Sync, I could also solve this problem via:

  1. Go into System Preferences
  2. Extensions
  3. In the left sidebar, choose "Finder"
  4. Disable Google Drive Extension
  • I have NO idea why this worked, but it did. I only allow GoogleDrive to sync certain directories and the Desktop is not one of them... but when I quit the Google Drive sync app then my screenshots make nigh instantaneous again. – Kenny Wyland Dec 12 '17 at 22:13
  • thanks for working solution, but after mac restart, the option in extensions for google drive will be set to active again! :/ – Sid Feb 5 '18 at 10:34
  • instantly resolved. cheers – patnz Feb 5 '18 at 23:02
  • For me it actually was the Adobe Core Sync Helper, not Google Drive. This solution worked great on MacOS Mojave (10.14.4) though. – Orun Apr 5 at 16:09
4

I had the same problem.

I did the following:

  1. Go into System Preferences
  2. Extensions
  3. In the left sidebar, choose "Finder"
  4. Disable Sophos (my virus software)

This may or may not be wise, but it helps to know why it slowed down--the virus software wanted to scan the file to see if it was safe.

  • Welcome to Ask Different. This answer is extremely similar to one already provided. It should probably have been a comment and not a stand-alone answer. See How to Answer for good info on providing quality answers. - From Review – fsb May 22 '18 at 20:55
4

On OS X Mojave, the problem is solved by disabling the "floating thumbnail feature" like this:

CMD + SHIFT + 5 -> Options -> [Uncheck] Show Floating Thumbnail

Enjoy!

  • I have that option unchecked and the timer to none but it still takes a lot of time to show up. I guess it's Google backup and sync – gota Aug 1 at 9:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .