2

I have upgraded to El Capitan a few months ago. I have followed a few guides to install and setup AMP: Get Apache, MySQL, PHP and phpMyAdmin working on OSX 10.11 El Capitan

But I can't access my /Sites folder, because I can't connect to "localhost".

  1. localhost (I actually tried with "localhost" typed in the address bar, and with my machine's address 192.etc) doesn't display "It works" message, instead I see this:

    Your website.
    
    Create and publish your own website quickly and easily using iWeb, Pages, and many other applications available for Mac OS X.
    

    and a few other sentences.

  2. neither localhost/~username (username = my name), nor localhost/username work - Safari displays a message that it can't connect to the localhost.

  3. and of course I can't reach my Sites folder, because two previous steps don't work.

    httpd -v
    Server version: Apache/2.4.18 (Unix)
    Server built:   Feb 20 2016 20:03:19
    

Apache configtest is successful:

apachectl configtest
Syntax OK

I have seen these discussions/pages:

but I am not sure if this is applicable to my situation.

Aslo, what's surprising, given the situation with apache, is that I can access phpmyadmin and mysql tables.

I will be grateful for your help!

  • I wasn't allowed to post other links I used due to lack of points, so I add them here discussions.apple.com/docs/DOC-3083 wpguru.co.uk/2015/11/… and others. – Vitale Dec 9 '16 at 12:53
  • @klanomath, Thank you very much. Sorry, but how did you do that? I mean adding links, etc? – Vitale Dec 9 '16 at 13:12
  • After gaining another 5 reputation points (now 6, then 11) your are allowed to add as many links as you want/need in your contribution. After gaining 2000 reputation points a user can freely edit anything without anyone else needed to review the edit. To add a link you can use the link symbol - the third symbot in the edit mode toolbar. – klanomath Dec 9 '16 at 13:19
  • Apache is working. The site you got is Apple's version of the generic "It's Working!" page. What's happening is that per user directories are not enabled and this must be done in httpd.conf – Allan Dec 9 '16 at 15:02
  • @Allan Thank you very much; I will read this to see what I have missed, though it seems I have uncommented all necessary items in httpd.conf - I have checked it numerous times. But I have to study the page you suggested. – Vitale Dec 9 '16 at 18:18

You must log in to answer this question.

Browse other questions tagged .