3

I just connected a Bluetooth headset (Urbanears Plattan ADV Wireless) to my OSX Sierra Macbook for the first time, mostly without issue. Then I realised my "Play stereo audio as mono" setting (Accessibility -> Audio) wasn't being respected anymore.

When I plugged in the optional cable, the output became mono, so I read up a bit on how Bluetooth works with sound. If I understood correctly, you basically have the choice between HSP, which is telephone-quality mono, and A2DP, which is high-quality stereo. Interestingly, a colleague claims his Bose Bluetooth headphones respect the "Play stereo as mono" setting fine, so likely the error is with this particular model.

What I'm wondering is, is there a way to force the output from the Macbook to the headphones to be mono anyway (without switching to HSP, as that brings the quality way down)? I'd have thought the Accessibility setting would have taken care of this - eg. mixed the channels together before sending the audio over to Bluetooth - but apparently something happens and I get stereo out anyway. Is it possible to circumvent this? I'm not a seasoned Mac user by any means, but I'm a developer and as such fine with digging around in the system, if that's what's needed.

If not possible, anyone have some clarity to offer on why?

(FWIW, this is an actual accessibility issue - I'm deaf in one ear, so I can't just stick to stereo and move on with my life. For now my options are either cabled, low quality, or only hearing half of the audio, neither of which is great.)

You must log in to answer this question.

Browse other questions tagged .