1

I get the error message:

Xcode Can't be opened. "Xcode" is damaged and can't be opened. Delete "Xcode" and download it again from the App Store.

I get this message for every app I have from the app store on my computer. I had TextWrangler installed from the appstore and it was doing this, so I downloaded a different version of it online somewhere - and it works fine. Apps such as iMovie, GarageBand etc. all give this message.

I have tried rebooting. Many times.

I have deleted and re-downloaded these apps many times as well.

I've tried running terminal commands such as:

xattr -rc /Applications/Xcode.app

and

killall -KILL storeaccountd

I've tried opening these apps from a different user on this Mac, and I've tried signing out from the appstore and signing back in.

I've also tried running these apps while booted in safe mode, and still get this error every time.

Any help would be appreciated.

1

Last year a lot of users had the same problem. It was caused by an expired security certificate, there system did not receive a new one yet.

I know you already tried a lot. But the right order is important:

  1. Delete the apps from your Mac.
  2. Log out of the Mac App Store (from the menu bar, choose Store > Sign Out).
  3. Reboot your Mac.
  4. Log back in to the App Store (Store > Sign In).
  5. Download apps again

If this doesn’t help, I have also heard reports that this issue can be solved by temporarily creating a new administrator user account on your Mac.

  • I just did those steps, still no apps from the app store will open. And I have tried making a new administrator user account and running them there; didn't work either – Fart Dec 10 '16 at 19:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .