7

Where is the list of sidebar's favourites stored in macOS Sierra? I tried to delete ~/Library/Preferences/com.applde.finder.plist and ~/Library/Preferences/com.applde.sidebarlist.plist - almost all preferences are reset except list of favourites - it remains

10

Thanks to @TonyWilliams for the starting point and after a brief research I realized that requested sidebar's favourites are stored actually in directory ~/Library/Application Support/com.apple.sharedfilelist/, the file com.apple.LSSharedFileList.FavoriteItems.sfl among other files which are responsible for other sidebar sections. But those files are not available for easy editing.

Starting from OSX El Capitan and newer versions there is a command-line tool sfltool availabe to make some operations with that files, such as add an item. But this tools doesn't have ability to remove items (the root of my problem which causes to this research) and I found another good tool on GitHub called mysides which allows to remove items as well.

  • 1
    That allowed me to see that the permanently appearing item cannot be deleted. When I tried to delete (see first screenshot) "Desktop" item I got an error, but the command mysides list helped me to try firstly remove AirDrop from list (via Finder Preferences) and repeat operation on the updated list. The result was positive – jctim Dec 12 '16 at 23:02
  • 1
    Not to mention that sfltool is awful. You can't check to see if an item already exists. You can't specify where it gets added and if you add it twice it will be in the list twice. As I said, futzing with the Sidebar is pain and suffering. – Tony Williams Dec 13 '16 at 4:52
  • Apple deprecated sfltool see here: openradar.appspot.com/radar?id=4985135170584576 – Andy Jan 10 at 19:15
3

The sidebar's favourites are managed by sharedfilelistd which is an XPC service, don't try to manipulate it manually. This way lies pain and suffering.

  • Hi @Tony, thanks for that knowledge. Maybe you can help with following: In my sidebar the Desktop icon appears from time to time and I cannot remove it permanently – jctim Dec 12 '16 at 10:34
  • If it's appearing then disappearing there's something seriously wrong with your install. If it refuses to disappear then I suspect that the OS just automatically replaces it at boot, but I'd have to do some testing :) – Tony Williams Dec 12 '16 at 21:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .