3

Mac Mini mid 2011 (5,1) 2.3 GHz i5, 2 GB ram running 10.12.1 with 149/500 GB free.

In application monitor everything (memory, disk, network, cpu usage) is nominal.

Disk check (Cmd+R at boot) - Passed

Hardware test (opt+D at boot) - Passed.

On boot the screen goes white after 45 seconds (half of the boot loading bar) and the dock shows up after about 5 minutes. The top bar take lot longer.

Safe mode - still slow as molasses. 78 seconds to launch a new Finder window. Over 5 minutes for System Preferences. Over 5 more to launch any of said preferences (if they don't fail to open)

Already reset the SMC and PRAM. Turned off all spotlight indexing though that wouldn't affect safe mode. Nothing plugged in besides a keyboard, mouse, monitor and Ethernet cable. Tried single sticking each RAM module. Really banging my head against the wall here. Even ssh'ing in from another machine on the network is a drag. 'ls' of a directory with 12 files takes 4 seconds.

Oh and Console keeps crashing. Because of course.

Could anyone recommend a next step?

EDIT: output of vm_stat after a fresh boot into safe mode

Mach Virtual Memory Statistics: (page size of 4096 bytes)
Pages free:                                3827.
Pages active:                            103786.
Pages inactive:                          100841.
Pages speculative:                         3730.
Pages throttled:                              0.
Pages wired down:                        118363.
Pages purgeable:                              0.
"Translation faults":                   4213483.
Pages copy-on-write:                    1353750.
Pages zero filled:                       779909.
Pages reactivated:                       566180.
Pages purged:                              9028.
File-backed pages:                        69729.
Anonymous pages:                         138628.
Pages stored in compressor:              526296.
Pages occupied by compressor:            193246.
Decompressions:                          310835.
Compressions:                           1264824.
Pageins:                                 837784.
Pageouts:                                  1602.
Swapins:                                   2409.
Swapouts:                                  3813.
  • What can you share by way of context? For example, when did this behaviour start? Have you recently installed/updated/upgraded anything? Added any new hardware? Also, have you got access to another Mac? If so, what model? – Monomeeth Dec 8 '16 at 0:20
  • 1
    Another simple test you could do, is create a totally new User Account. Once created, shutdown your Mac and restart, logging in only on the new User Account. Do you still experience the same issues? – Monomeeth Dec 8 '16 at 0:22
  • was able to get into my system.log Loads of" "Failed to harvest strings for pathless uuid" and "metadata shared cached uuid is null" – OBoud Dec 8 '16 at 0:42
  • @Monomeeth I use it as a media center and mostly click "later" for the constant app store updates. I must have hit "reboot". Would a new user account show me anything rebooting in safe mode doesn't? Keep in mind, the boot times are looooong. – OBoud Dec 8 '16 at 0:58
  • 1
    2GB of RAM and the hard drive are your main issues. – At0mic Dec 8 '16 at 14:19
1

It sounds like a lot of the speed problems you're having comes from running newer software, macOS 10.12, that usually requires more system resources on a computer that has insufficient RAM (2 GB just does not cut it practically) and a slower HDD. However I don't think that would normally cause quite the amount of speed reduction as you have reported.

Nevertheless, for a quick speed boost, I would definitely recommend upgrading to 8 GB of RAM. Apple has information on how to upgrade, just make sure that the RAM you get is compatible with Apple's specifications. For example an 8 GB RAM kit from Crucial should work.

Additionally, I do know that HDDs can be a speed bottle neck, especially as they get more full and are older. You can upgrade to an SSD (here's a guide by Crucial), however that is a far more complicated process, and you will also need to transfer all your software from the old HDD.

But your speeds are very slow, so there is probably some software problem. You can try to diagnose that by going to System Preferences > Users & Groups > Login Items and see if you have programs loading at boot. Also if you can check Activity Monitor, that may show if something is using a lot of your CPU. In the end, you may need to do a backup, wipe your hard drive, reinstall macOS or an older version of OS X, and transfer your documents and settings.

  • I don't think it's a ram issue as activity monitor shows it's only using about 85% of the available memory. Nothing taxing the cpu either. I thought I saw an improvement earlier today when I went from 12% to 30% free space on the on the hard drive but I think that was placebo effect. Problem persists when all login items are unchecked for reboot. Can't be one of those though as I see the same problem in safe mode anyway. – OBoud Dec 8 '16 at 0:55
  • It could still be a RAM problem. It doesn't show 100% because whatever it doesn't most need it writes to the HDD (which is also a lot of why SSDs are much faster, they write faster than HDDs). So it may write stuff to the HDD and ends up with less than 100% being actively used by the RAM. For me, after upgrading RAM, the Mac does take advantage of it even if it wasn't at 100% before. I have 10.11 on my 2011 MBP, upgraded from 2 GB to 4 GB and later to 8 GB of RAM. With everything closed, right now it shows 2.85 GB used and 2.47 for cashed files. 8 GB will help, the question is how much. – kal-al Dec 8 '16 at 2:12
  • @OBoud In Activity Monitor near the bottom under Memory Pressure, that should be green. If it has red, you need more RAM. – kal-al Dec 8 '16 at 2:25
  • swap usage seems low to me. Generally the pagein()/pageouts() both sits at 0 when idle and hit a couple hundred when launching something so there doesn't seem to be any trashing going on. Swap file is around 300 MB with a few things open in safe mode. (I'm not trying to argue with you. I'd love "more memory" to be the solution. I just don't want to go dropping any money into this thing without having a little more confidence.) – OBoud Dec 8 '16 at 13:05
  • 1
    Dropping in 16GB helped considerably. I'm sure a SSD upgrade will take it the rest of the way. – OBoud Dec 15 '16 at 15:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .