1

I've been considering to move from OS X to Linux, because I want to have full control over the source code of the os and the apps I use, and Linux and open-source software allows me that in general, without having to go against the EULA.

Bearing this in mind, I installed Fedora 25 on my Mac. I created a Live USB, with the given app for OS X, which I used to boot. I had no problems doing so, but after a while I started feeling like the os was not only comprising my hardware stability, but also there were a few tiny little bugs, which I didn't want to mess around. Furthermore, two days after installing the os, I had problems with the boot loader, and I had to format the computer again. Furthermore, I don't have graphics acceleration in my graphics card, and the Planet CCRMA repositories, which were the main reason why I moved to fedora 25, don't seem to work on my install.

Bearing all of this in mind, I want to know how can I move back to OS X, creating an OS X installer thumb drive straight in Linux. I tried doing so throughout three possible ways:

  1. I tried to run createinstallmedia from the installaton disk, which didn't work out (I currently have a hard drive in the place of the dvd drive) - the command for doing so doesn't run in Linux, because it cannot run the specific binaries.

  2. I tried to create an install media with sudo dd if=x of=y, straight after using dmg2iso command but it turned out not to work, simply because this has to be done using the predeceasing bash utility.

  3. Finally, I tried to use an app called UNetbootin, but for some reason, it doesn't recognize the USB disk I need to use as a target, making it worthless (probably the software is needing some maintainance to work fine on Fedora 25)

  • my mac model is basically a1278 – tmm88 Dec 7 '16 at 13:42
  • A1278 include mid2008 - mid 2012 MBPs. All Macs built after ~2010/2011 can boot to Internet Recovery Mode and reinstall OS X. So add something like MBP 13" Late 2011. – klanomath Dec 7 '16 at 13:45
  • the problem is that i accidentally removed my recovery partition. fedora installer did it. so i really need a live usb. i have an iso containing the os, i just need to burn it properly to an usb drive, which i also have. but i need to do that from linux, which is the only os i currently have available – tmm88 Dec 7 '16 at 13:47
  • so, can you please tell me how can i access this mode? kind regards. tiago – tmm88 Dec 7 '16 at 13:48
  • command option r, i've seen it. going to try it now – tmm88 Dec 7 '16 at 13:49
0

thanks to klanomath, i realized that there was a much simpler way to fix this issue. it basically consists of: pressing alt command r in boot, to enter internet recovery. please notice that this will only work in macintosh computers released after 2010-2011. after doing so, the computer will connect to the internet and you will be able to download the stock version of your os from the cloud. after doing so, install it, then boot into the os. if it is like a really old version, you can boot into recovery mode (now installed). and download the latest version. if this procedure doesn't work, you can also download the latest version of macosx, and using createinstallmedia command in installation media, and install the latest version of osx

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .