51

Changing languages input does not work, you can see the video.

3
  • 1
    happens once in a while, have to restart OS.
    – georgexsh
    Jul 26 '17 at 17:57
  • 1
    Fixed for me by using "select previous input source" instead of "next", as suggested by Yahuen Yakimovich below. Did not change Siri settings or anything else, FWIW. (On Mojave)
    – Kalle
    Dec 1 '19 at 6:14
  • 2
    I have the same problem in 2021. The only thing that works is restarting. Imagine paying 3000 dollars and you cant change the damn input language Apr 19 at 1:43

12 Answers 12

37

Go to system preferences/Siri and turn off Siri and make sure that the keyboard shortcut is set to None, and then restart.

8
  • apparently OP doesn't have Siri.
    – georgexsh
    Jul 26 '17 at 17:54
  • 3
    2019 and it still present in Mojave... Jul 9 '19 at 2:28
  • 2
    Thank you so much!!! I almost started to hate my laptop, but now this annoying problem is finally fixed!
    – erkfel
    Sep 3 '19 at 16:47
  • 3
    2020 and it still present in catalina
    – ospider
    Sep 6 '20 at 6:36
  • 4
    2021 and it still present in Big Sur / Apple Silicon Mar 23 at 13:16
10

Had this happening to me every once in a while. Console did emitted an error when I attempted to switch the keyboard layout:

TypingFocusDebug senderProcess is non-trustable, senderProcessPID is 6171 typingFocusProcessPID is 35651 -> msgID = -1

The senderProcessPID was /System/Library/PrivateFrameworks/LocalAuthenticationUI.framework/Versions/A/XPCServices/localAuthenticationRemoteService.xpc/Contents/MacOS/localAuthenticationRemoteService

Killing it did helped to get rid of the non-switching input source problem:

sudo killall -9 localAuthenticationRemoteService

Hope this helps others who are having the same issue.

1
  • 2
    only this sudo killall -9 localAuthenticationRemoteService was enough to make it work on my side
    – Kristian
    Mar 25 '20 at 14:52
5

Had a similar problem with the variation that I needed to change focus of the window (deactivate and activate currently focused application window by using command+tab, very annoying).

I am extending the solution with Siri (which I am not certain about if that is really solving the problem but I don't use it anyway) with what has worked for me:

  1. Turn off Siri in System preferences (reboot as explained by Tom)
  2. Use method with Select the previous input source.
  3. Don't use Select next source in Input menu

The difference in how those two methods (2) and (3) are implemented causes only (2) to work properly, since it shows a menu popup where user can loop over languages. This results in missing defocus/focus step.

Hope that helps!

1
  • 1
    Thank you! Using "Select previous input source" instead of "next" solved this for me. I did not do anything else, like turning off Siri. (Mojave)
    – Kalle
    Dec 1 '19 at 6:13
3

killing of this process will be enough

/System/Library/Input Methods/PressAndHold.app/Contents/PlugIns/PAH_Extension.appex/Contents/MacOS/PAH_Extension

if this will not help, try kill these processes as well

/System/Library/CoreServices/TextInputMenuAgent.app/Contents/MacOS/TextInputMenuAgent
/System/Library/CoreServices/TextInputSwitcher.app/Contents/MacOS/TextInputSwitcher

update:

sudo killall -9 PAH_Extension TextInputMenuAgent TextInputSwitcher
0
2

I have similar issues. As shown in the video or another one where instead of having n+1 languages I suddenly can only switch between 1 language even though I have n+1. It seems the process freaked itself out or whatever. To fix it I went into keyboard preferences -> shortcuts -> deselect "Select the previous input source" or "Select next source in Input menu" whichever you are using. Afterwards close preferences and reopen it. Go to shortcuts again and enable the option you like to use.

Seems that restarts the process.

4
  • Which IS the correct ANSWER ! Mar 11 '20 at 7:49
  • Would be nice to know which process we need to restart so there is a general solution though.
    – steros
    Mar 11 '20 at 8:27
  • I did not have to restart any process, the update simply had a bug to not be able to "remember" my shortcuts preferences ... so the simple re-applying of the preferences worked for me ... Mar 11 '20 at 8:42
  • 2
    For OSX Catalina users, these options can be found like so: System Preferences -> Keyboard -> Shortcuts -> Input Sources. Be sure to use the Input Sources shown in the side bar of the Shortcuts window, NOT the the tab directly next to Shortcuts.
    – Wimateeka
    Aug 12 '20 at 20:08
1

I had same issue. As english layout I had ABC.
So I added US layout instead ABC and after removing ABC problem has gone.

2
  • Interesting! What language were you switching with? Russian like Sato? May 25 '18 at 14:27
  • @TomGewecke Yes, Russian <-> US
    – Sonique
    May 25 '18 at 14:28
1

Yes. I have had different issues with inputs since El Capitan. I frequently switches between Japanese and English. I don't know about Korean but in Japanese, you've got Katakana and Hinagana so I basically have 3 input turned on (but I don't think that's why I got the issue).

And every now and then either Japanese or English input stops working. The flag at the right corner did change with keys. But the inputs themself don't.

for example. If I'm using pages, and switching between chrome and pages when I type something in English on chrome then switch back to pages to type something in Japanese, the language won't change even if the icon changed. and if this issue happened it stays.No matter what the icon is the actual input would be either English or Japanese.

I have to reboot the mac to fix it, but it comes back a few hours after the machine is heavily used.

1

On my Mac (Catalina 10.15.3), it usually happens after authenticating with Apple Watch when editing Safari's stored Credit Cards and in some other cases that require an authentication.

In order to fix it, just run the command:

sudo killall -9 localAuthenticationRemoteService

This will restart the Authentication Remote Service, the one that causing the problem.

0

I finally found a satisfactory way to temporarily fix this on my computer (running Sierra 10.12.6) WITHOUT REBOOTING! Even opened an account on StackExchange to share :)

First, my symptoms: at some point the keyboard stops switching between English and my OtherLanguage. It doesn't matter if I use a keyboard shortcut for switching or try to switch in the menu bar. What happens is I BRIEFLY see the flag of my OtherLanguage, and then when I try to type, it switches back to English.

However... I noticed that this behaviour is application-specific. Some "cooperative" applications (in my case Terminal) still allow me to switch (using any method) AND STAY with the OtherLanguage layout. This gives me some hope...

Unfortunately, in my case rebooting is not an option, so I kept experimenting. First, I quit the applications that were "uncooperative" (Safari, Mail, Skype, Slack). Brought them back again - no effect.

Then I quit them again, switched to my trusty Terminal, CHANGED THE INPUT SOURCE and only then restarted Skype - Skype gave me my OtherLanguage back! Repeated the same with Slack - it worked too! Repeated with Safari - it worked again! Repeated with Mail - no way :(

However I can live with that for the time being. For example, I can type my text in another application and just paste into my Mail as a temporary fix.

Hope it helps someone out there!

0

In my case, running Big Sur on an M1-powered Macbook Air, the globe/fn key randomly stops responding.

In System Preferences / Keyboard / Shortcuts / Input Sources I found these:

  • Select the previous input source: [control]-Space
  • Select the next source in input menu: [control]-[option]-Space

The first key combination doesn't actually seem to do anything I can notice, but the second not only switches between language keyboard layouts like the globe/fn key should, but it also makes the globe/fn key start working again.

2
  • This really has no connection with the question from 5 years ago. It belongs with this other topic: apple.stackexchange.com/questions/411715/… Apr 5 at 4:31
  • @TomGewecke: Hmm that one well eluded my multiple search efforts. This one here seems to actually cover several separate problems. I'll take a look at the other one. Apr 5 at 10:03
0

If you added an alternative keyboard layout, remove it and then re-add it (i.e. the layout that the os keeps switching away from).

I tried 90% of the solution here, and this was the only one that worked (Monterey 12.0.1).

(Credits to DanSkeel for pointing this out in a comment to a different answer).

-1

This bothered me for almost a whole year. It turns out a very bad and messy design plus bugs caused the widespread frustration.

Solution is to only use the correct behaviors (hereafter quoted as below):

In input settings, I enabled switching input method by Caps-lock key. When everything works fine, here are the behaviors should be:

Correct behaviors

Using caps-lock to switch Chinese input method and English. That means:

  1. when using Chinese, press caps-lock will turn input method to English
  2. when using Chinese, long press caps-lock will turn input method to Capital English, green light will be on in Apple Magic Keyboard.
  3. when using English, long press caps-lock to switch to Capital English, long press caps-lock to go back
  4. when using English(whether Capital or not), press caps-lock to switch to Chinese

Incorrect behaviors

first(very common)

  1. pressing caps-lock does switch input method, but the indicator in menubar doesn't change accordingly at all.

second(very common)

  1. pressing caps-lock does not switch input method any more. But cmd+space still works. menubar indicator works as well.

third(less common)

  1. press caps-lock and cmd+space both don't work. I have to use mouse to click the menubar indicator to switch input method.

fourth(rare)

  1. press caps-lock and cmd+space both don't work. Even more, when I use cmd+space, I could see only the English input method or the Chinese input method was gray. Both were gray in cmd+space and in menubar indicator.

The original link: https://forums.macrumors.com/threads/is-there-a-bug-with-language-switching-in-sierra.2020165/#post-24054565

3
  • 11
    I don't understand the "solution". You are just cataloging how it is supposed to work and then how if often does not work. When it does not work right, what are you supposed to do to fix it? Using "correct behavior" is not an option when you are faced with "incorrect behavior". Jul 15 '17 at 11:15
  • @TomGewecke agree, but IMHO sort out things is a bit more helpful than a unrelated "solution".
    – georgexsh
    Jul 26 '17 at 17:56
  • 3
    Your stuff is really addressed to Apple, not to anyone with a concrete problem to solve. Instead of posting it here, send it to apple.com/feedback Jul 26 '17 at 18:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .