2

I am unable to access certain websites within Chrome. I am getting the error message "Your connection is not private". Anyone know how to fix this?

I've already tried the following: Cleared cache and cookies, resetting the browser, reinstalling the browser, downgrading/upgrading the browser (happens on multiple versions of Chrome) and same websites work in Firefox and Safari. I've corrected the time and that did not fix the issue. I ran the command sudo ntpdate -u time.apple.com

enter image description here

  • Have you tried the three answers below? Did any help? – owlswipe Dec 7 '16 at 12:11
  • What do you see when clicking the red https on top. It will show you the certificate or url the certificate is pulled from. – Rob Dec 18 '16 at 15:49
2

Click on the Advanced link on the bottom left. It will show you an option to continue on to the site you want to visit.

Chrome will show you this page if it finds problems with certificates, http vs https, etc. It's just to let you know that it thinks something's not right and it gives you the option to continue or go back.

  • There is no longer any button for: Continue to site – neoneye Nov 6 '18 at 10:38
  • @neoneye This question is almost 2 years old so what version of Chrome are you referring to? – fsb Nov 6 '18 at 12:38
  • The current version of Chrome 70.0.3538.77 (Official Build) (64-bit) – neoneye Nov 6 '18 at 13:53
1

Are you on a VPN of any sort (like a work network)?

This error warns you of a Man in the Middle Attack (MITM). This means that there is potentially someone sitting between you and the website (main.yahoo.com) and trying to intercept the back and forth communication. Chrome thinks this because mail.yahoo.com uses https and https sites are supposed to provide a certificate. In this case Chrome thinks the certificate that it gets is not a good certificate (That's why CERT_AUTHORITY_INVALID).

This happens if there is a really someone spoofing the network or if you are on a VPM of some sort like a work network. Some work networks use a self signed certificates that Chrome generally does not like. Some anti virus, firewall or other kind of network software may also cause this.

See also the steps to resolve this error in google help here: https://support.google.com/chrome/answer/6098869?hl=en

-1

The most common cause of this issue is an incorrect date & time set on your PC. Chrome makes sure that your computer's clock matches the clock in a Google server farm, and if it doesn't, will block the connection to HTTPS sites for security reasons.

To fix your issue, set your computer's clock to the correct current time.

  1. Go to System Preferences
  2. Choose Date & Time
  3. Navigate to the Date & Time tab
  4. Change the current time to the correct time (accurate to the nearest minute will do).

Edit: If it's not your computer's fault, it's just a Chrome security feature. Chrome detects malicious activity going on with the site (like malware-laced ads, breach by hackers, etc.) and automatically warns you to protect you if it believes your security or safety might be at risk. If you want to override the warning, just hit Advanced -> Continue to site.

  • Hello, I've corrected the time and that did not fix the issue. I ran the command sudo ntpdate -u time.apple.com – MacMania Dec 7 '16 at 20:56
  • @MacMania OK. Are the warnings happening for all different sites or are they only happening on yahoo.com? – owlswipe Dec 7 '16 at 21:53
-1

The simplest method I often use to bypass this is to click on the Advanced link and then Process to the site.

In most cases, this connection error occurs because your computer has a wrong date & time. You need to check it as well.

You can also ignore the ssl from the Google Chrome shortcut by adding this code: "--ignore-certificate-errors", according this guide.

If the problem persists, I would recommend you to uninstall your Google Chrome, download a new & latest version and reinstall it. Before doing so, make sure you have backup it with ChromeSync or manually, in order to restore all data back when reinstalling the Chrome browser.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .