1

enter image description here

So, I was trying to add Laravel to my list of executable commands and, somehow, I fudged up my iTerm 2 (and regular Terminal) and now they both appear like this.

MacBook-Pro%

That just looks ugly. How do I change back to what it once was? With the Git indicator, folder name, colors, etc.

3
nano .bash_profile

Then add:

export PS1=" "

Between those quotation marks, add any of the following between the quotation marks of export PS1=" ":

\d – Current date
\t – Current time
\h – Host name
\# – Command number
\u – User name
\W – Current working directory (ie: Desktop/)
\w – Current working directory with full path (ie: /Users/Admin/Desktop/)

Also you can customize the look and feel of terminal, or restore the defaults in Terminal > Preferences > Profiles

http://osxdaily.com/2006/12/11/how-to-customize-your-terminal-prompt/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .