-1

This question already has an answer here:

I have an iPhone 4 with iOS 71. I can't install apps from app store because when tap on install button of any app then showing error message " you most be update your iso device 8.0 or later version and try again..."

What can I do to install Facebook etc.?

marked as duplicate by nohillside Dec 20 '16 at 6:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • It looks to me that the answer is in the error message you posted. Could you give more details - what happened when you tried to update your device to iOS 8.0 (or later), etc? – John N Dec 5 '16 at 20:17
0

I've been burned by this a couple times. On the app store if you look carefully it will give you system requirements. Lots of apps have a minimum iOS level.

So if you want an app that needs iOS 8 you need to upgrade your phone.

For most of this we need to want an app really badly to fork out that kind of money. Look for other apps with similar functionality.

Unfortunately the iTunes app store doesn't give you a filter to weed out the ones that won't work. Google is your friend here. Try

iphone app "iOS 7" | "iOS 6"  followed by the keywords for the type of functionality.

Not the answer you're looking for? Browse other questions tagged .