22

I'm experiencing extreme ping spikes to my AirPort Extreme (local IP: 192.168.1.1), however I am not getting these ping spikes on another MacBook Pro right next to it.

Here are my ping results.

PING 192.168.1.1 (192.168.1.1): 56 data bytes
64 bytes from 192.168.1.1: icmp_seq=0 ttl=64 time=24.703 ms
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=145.378 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=975.540 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=577.900 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=2.802 ms
64 bytes from 192.168.1.1: icmp_seq=5 ttl=64 time=5.377 ms
64 bytes from 192.168.1.1: icmp_seq=6 ttl=64 time=5.922 ms
64 bytes from 192.168.1.1: icmp_seq=7 ttl=64 time=3.854 ms
64 bytes from 192.168.1.1: icmp_seq=8 ttl=64 time=3.522 ms
64 bytes from 192.168.1.1: icmp_seq=9 ttl=64 time=4.593 ms

--- 192.168.1.1 ping statistics ---
10 packets transmitted, 10 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 2.802/174.959/975.540/316.450 ms

MacBook Pro (Retina, 13-inch, Early 2015)

  • Have you disconnected all wi-fi or hard-wired devices (other computers, including iDevices, AppleTV(s), home automation devices, etc,) from the APEx , except for the device you are sending the pings? From these brief blips I would assume the APEx is connecting to the external network for some reason. Let it run for at least 100 iterations (or more) and see if there is some sort of pattern which would indicate a process on the APEx periodically 'phoning home'. Report back with what you see. Don't paste in a huge ping listing, please. :-) – IconDaemon Jul 21 '17 at 12:25
  • IMHO I found the ping listing helpful – Brian Low Mar 12 '18 at 3:57
17

I'm posting this reply on a few threads to make it easier to find. I chased the same issue and finally found the cause.

Locationd. Open the console app and watch while you do a continuous ping. Every time you see latency spike, you'll see entries for locationd. Go to system prefs->security & privacy->location servers. From there, you can disable and you'll likely see the problem disappear. However, you lose the "find my mac" ability.

What made mine acceptable was going to system services (scroll down)->details->check show icon in menu bar when [...]. Then, take look at what is requesting location. Disallowing Evernote helped a lot. I pruned down to the minimum and the frequency of the spikes has gone down to an acceptable level for me.

edit: filed a bug with Apple because even when location services are disabled, locationd scans (verified in console), impacting latency. Apple marked it as a dupe, so hopefully fixed soon.

  • 2
    Can confirm that I'm also seeing these latency spikes that directly correspond to locationd entries in the Console and disabling location services eliminates the spikes. Handy tip: There's an option in ping that'll include a timestamp making it easy to x-ref the logs: ping -i 0.25 192.168.1.1 --apple-time – Ryan Dlugosz Oct 23 '18 at 17:15
  • 1
    OP: This should really be the accepted the answer @C-regan! I've been trying everything and this is the rule. If the latency spikes only happen on macosx and you have tried at least 2 different APs this is very likely the answer to your problem! – Luca Gibelli Dec 13 '18 at 13:23
  • @user163253 in my case I solved the problem by disabling only some location services, in particular: Weather, Maps, Locations-Based Suggestions, Setting Time Zone, Significant Locations. I still have the following services ON: Calendar, Reminders, Find my mac, Wifi Networks. I suppose the latter are not used as frequently as the former and therefore they have minimal impact on latency. I also noticed that reducing the number of known/saved wifi networks under Network->WiFi->Advanced mitigates the problem.. – Luca Gibelli Dec 13 '18 at 14:16
  • Man, you are a lifesaver! – KARASZI István May 4 at 13:40
  • I narrowed it down further to specifically the "Time Zone & System Customization" checkbox inside "System Services". I think that is attempting to quickly disconnect from the access point and scan for Wifi access points to get the current time, time zone, and location. – Brandon May 15 at 16:01
11

I've had exactly the same problem, it was troubling me quite a long time. It is especially annoying when working remotely over SSH or playing multiplayer games. Here is my long-term solution:

Diagnosis

Run ping with frequency 10 scans per second to see when is the glitch occurring:

ping 8.8.8.8 -i 0.1

Scanning & Location services

As mentioned by others, WiFi spikes are typically caused by WiFi daemon scanning another WiFi networks around. The scanning goes through all channels so if the current receiving channel is not the same as your AP is transmitting, you have a ping spike.

The scanning is usually triggered by location services. You can review the location services in: System Preferences -> Security & Privacy -> Privacy tab -> Location Services.

Location services

If you go to Advanced check the Show location icon in the menu bar... to see when the apps are querying location thus scanning WiFi neighborhood.

Location services were still active because of System services. Mainly Time Zone & System Customisation and Significant Locations. But after turning that off I still had a WiFi glitch in spite of that Location setting window showed no other application acquiring the location.

Finding the culprit

You need to enable WiFi logging to see why is WiFi daemon doing the scan.

Hold option/alt key (next to the command key) and click WiFi icon in the top toolbar. Click Enable Wi-Fi Logging.

Enable Wi-Fi logging

After that open a new terminal:

tail -f /var/log/wifi.log

You should see something like this:

Mon Jan 14 20:01:21.353 AutoJoin: <airportd[83093]> Successful cache-assisted scan request for texstudio with channels {(
Mon Jan 14 20:01:21.353     <CWChannel: 0x7fbcfadc5b20> [channelNumber=56(5GHz), channelWidth={40MHz(-1)}, active, DFS],
Mon Jan 14 20:01:21.353     <CWChannel: 0x7fbcfadcbfb0> [channelNumber=60(5GHz), channelWidth={40MHz(+1)}, active, DFS],
Mon Jan 14 20:01:21.353     <CWChannel: 0x7fbcfd44c790> [channelNumber=64(5GHz), channelWidth={40MHz(-1)}, active, DFS],
Mon Jan 14 20:01:21.353     <CWChannel: 0x7fbcfadc6ba0> [channelNumber=149(5GHz), channelWidth={80MHz}, active],
Mon Jan 14 20:01:21.353     <CWChannel: 0x7fbcfad2be90> [channelNumber=153(5GHz), channelWidth={80MHz}, active],
Mon Jan 14 20:01:21.353     <CWChannel: 0x7fbcfadf4870> [channelNumber=157(5GHz), channelWidth={80MHz}, active]
Mon Jan 14 20:01:21.353 )} took 0.0005 seconds, returned 2 results
Mon Jan 14 20:01:21.353 Scan: <airportd[83093]> Cache-assisted scan request for texstudio on channel 161 does not require a live scan
Mon Jan 14 20:01:21.353 Scan: <airportd[83093]> Cache-assisted scan request for texstudio on channel 165 does not require a live scan
Mon Jan 14 20:01:21.353 Scan: <airportd[83093]> Cache-assisted scan request for texstudio on channel 100 does not require a live scan
Mon Jan 14 20:01:21.353 Scan: <airportd[83093]> Cache-assisted scan request for texstudio on channel 104 does not require a live scan
Mon Jan 14 20:01:21.353 Scan: <airportd[83093]> Cache-assisted scan request for texstudio on channel 108 does not require a live scan
Mon Jan 14 20:01:21.353 Scan: <airportd[83093]> Cache-assisted scan request for texstudio on channel 112 does not require a live scan
Mon Jan 14 20:01:21.353 Scan: <airportd[83093]> Cache-assisted scan request for texstudio does not require a live scan

Now observe ping terminal and wifi log terminal next to each other. You can clearly see the glitch occurrs precisely when WiFi is doing the scan.

In my case the culprit was a program texstudio, as you can see from the log. It was acquiring location every 5 seconds (wt.?), which was is confirmed also by this guy: https://justus.berlin/2016/04/reducing-cpu-load-and-energy-consumption-of-texstudio-on-the-mac/

This solved my problem. The Texstudio was not mentioned in the location services list so this advanced approach was necessary.

Summary:

  • The culprit is location services and wifi scanning
  • Check location services you have enabled
  • Hold Option keyboard key, click the WiFi icon in the top toolbar, click Enable Wi-Fi Logging
  • Execute in terminal: ping 8.8.8.8 -i 0.1
  • Execute in terminal: tail -f /var/log/wifi.log, in a new window. Observe side by side, wait for glitch.
  • Check the log when the glitch was observed, kill the program.
  • 1
    The tip on enabling wifi logging was key for me to track down the source – Jehiah Mar 29 at 0:45
  • Thanks for the extra details – M Johnson May 16 at 18:26
  • I find SystemUIServer and Joxi(app for screenshot). Thanks – Глеб Беляев Jul 11 at 10:03
3
+50

Please run this script from the Terminal.app:

while x=1; do /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport -I | grep Ctl; ping -c 1 192.168.1.1; sleep 1; done

This script checks for Signal/Noise ratio. You probably have some interference.

  • Can you provide some benchmarks so that we can know what acceptable numbers are? – Mike McKay Aug 26 at 17:12
  • SNR 20db is generally ok for file transfer, 25db is enough for voice – Siarhei Karatkevich Aug 27 at 15:36
2

From my experience, in 90% of all cases, restarting the router will fix the issue.

2

Following this guide worked for me:

Fix Wi-Fi problems on MacOs Sierra

essentially in the folder /Library/Preferences/SystemConfiguration/ backup and delete files

com.apple.airport.preferences.plist
com.apple.network.eapolclient.configuration.plist
com.apple.wifi.message-tracer.plist
NetworkInterfaces.plist
preferences.plist

Then restart your Mac.

  • Interesting - I've seen that buffering come and go - are you thinking that the WiFi is roaming to check other base stations and clearing those preferences / records out keep the WiFi connection more stable? – bmike Jul 21 '17 at 19:11
  • What about pinging a different node; say one of the other MacBooks on the network? Does the problem still exist? – Allan Jul 22 '17 at 0:40
1

In my case, it was an app for taking screenshots. I detected it by doing the following: I ran ping command and was closing apps one by one, then I noticed after closing this app, ping spikes had gone.

0

I have tracked similar problems to Airplay/Bonjour, ping spikes while airplay is in use or being checked.

I believe this behaviour is actually linked to the bluetooth of the device being linked with the wireless adapter in the device.

I am going to conduct some more tests soon and submit an apple bug report.

if you keep bluetooth disabled you will probably find you will get no ping spikes.

-1

The problem still occurs on Mojave, so let me put my two cents here. The source of the problem was locationd and to fix the spikes all I had to was to go to Settings -> Security & Privacy -> Location Services -> (System Services) Details -> uncheck "Time Zone & System Customization"

No idea why would the Mac check time zone every few minutes...

  • This is exactly what the top-voted answer already said & adds nothing new. – Tetsujin Aug 31 at 12:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .