0

I use ParagonNTFS on my Mac that I can write to ntfs drives.

I have two very large NTFS drives that I try to keep in sync. I'd like to be able to do this quickly with rsync:

rsync -rvh --delete /Volumes/Archive/ /Volumes/MobArchive/

Unfortunately, this command re-copies every file every time, including those that have not been updated. As a result, it takes all night to complete.

As a result, I have to use the --size-only option, which generally works as desired, except for files that have been updated but whose size has not changed.

I have read elsewhere that a common solution to this problem is to use --modify-window=1. In my case, however, this still causes all files to get copied. I have tried modify-window values all the way up to ten.

Any possible solutions?

3

If you change your command to start rsync -rvh ... to rsync -avh ... you should have more success.

The way you have the command just now rsync isn't copying over date stamps. The files in MobArchive will have their Create, Modify and Access times set to the time they are created in MobArchive. So every time rsync does a compare the date stamps in Archive and MobArchive will not match and it'll copy over everything again.

The "a" option (aka "archive" mode) is the equivalent of "-rlptgoD" which does a number of things including preserving timestamps.

  • Thank you! The actual option I needed was -t (since I don't want the full archive mode), but this pointed me in the direction I needed! – Wowfunhappy Dec 27 '16 at 17:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .