1

I have 2 external HD and everything is set up correctly as you'd expect. The one called "Time Machine" is set as the destination, and other drive, called "External HD", is in the exclusion list, and is not a target.

Yet TM continues to make Backups.backupdb folder appear on the other drive. This dir is very hard to delete. If you Trash it and try to empty the trash, it says it's in use, and every other error message you can think of, including that some files are protected by System Integrity Protection. The last time I had to turn off protection via csrutil and reboot just to finally empty the trash.

Additionally, "External HD" still shows the TM drive icon as well, just like the real TM drive. I know there're online workarounds for how to fix the icon, but my problem obviously goes beyond that.

For background, I'm on Sierra, 10.12.1. Also, as far as how this happened, I used to have a crappy USB hub, and drives would give out. When the TM drive wasn't available, TM would just take it upon itself to use the other external HD that was available at the time. So there're probably some system files that make it seem like a TM drive, although I'm not seeing anything obvious with ls -la.

Finally, reformatting is not an option for me, as I don't have enough space on the primary drive to move everything over from "External HD" just to wipe it.

To sum up, I think I need to 1) Remove any trace of TM from a drive and 2) fix its icon. Thanks in advance for any help.

1

The tmutil command should do the trick... in theory.

tmutil destinationinfo

should list the External HD and an associated ID string; feeding that string to

tmutil removedestination (destinationinfo_ID_string)

should stop Time Machine from backing up there; and

tmutil delete (path/to/the/wayward/"External HD"/backups)

should remove the backups from External HD--at least it did in 2012.

  • I managed to trash the dir again before this tip, and now it hasn't appeared, but I will try this right away when it comes back. Thanks, this absolutely looks like it would do the trick. I'll accept it as the answer if I can't reproduce the problem. – SilverSideDown Dec 6 '16 at 2:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .