0

I think I have some sort of dns/proxy issues with my wifi settings. Many apps cannot connect to the internet: Firefox, Team viewer, Steam (works after 2 minutes). Chrome does connect but "Establishing secure connection" message for 30+ seconds on each website.

Currently using my default ISP DNS but also tried Google public DNS. Proxy protocol: Auto Proxy Discovery (tried on and off) & Passive mode active.

I have cleared DNS cache multiple times, removed network multiple times and it only seems to be happening on this specific device: 2015 MBP Sierra.

Worth mentioning that this specific issue freezes my Mac for a good minute or so.

enter image description here

Anybody has any ideas regarding what is going on here? There is no proxy/dns settings on my router + it is a wireless connection.

My current settings:

enter image description here

Ping (8.8.8.8)

PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: icmp_seq=0 ttl=59 time=12.657 ms
64 bytes from 8.8.8.8: icmp_seq=1 ttl=59 time=12.514 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=59 time=11.507 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=59 time=12.764 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=59 time=13.733 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=59 time=12.591 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=59 time=11.241 ms
64 bytes from 8.8.8.8: icmp_seq=7 ttl=59 time=12.400 ms
64 bytes from 8.8.8.8: icmp_seq=8 ttl=59 time=21.485 ms
64 bytes from 8.8.8.8: icmp_seq=9 ttl=59 time=13.148 ms

--- 8.8.8.8 ping statistics ---
10 packets transmitted, 10 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 11.241/13.404/21.485/2.778 ms

Traceroute (8.8.8.8)

traceroute to 8.8.8.8 (8.8.8.8), 64 hops max, 72 byte packets
 1  * * *
 2  213.105.194.9 (213.105.194.9)  9.585 ms  12.063 ms  10.545 ms
 3  * * *
 4  62.253.175.34 (62.253.175.34)  11.010 ms  28.857 ms  11.516 ms
 5  74.125.48.190 (74.125.48.190)  17.485 ms  19.597 ms  16.406 ms
 6  72.14.232.215 (72.14.232.215)  17.545 ms  18.380 ms  15.319 ms
 7  216.239.57.79 (216.239.57.79)  18.027 ms  18.058 ms  18.314 ms
 8  8.8.8.8 (8.8.8.8)  11.559 ms  14.196 ms  11.014 ms

Update: I did a wifi test and got "DNS resolution failure"

  • What makes you think it's a DNS problem? How do ping our traceroute behave? – techraf Dec 1 '16 at 23:12
  • @techraf I can't really think of anything else since I have no firewall or any security set on the router. Ping & traceroute results added. – Abdul Sadik Yalcin Dec 3 '16 at 0:56
0

Go to: System Preferences - Network - Select your current adapter - Advanced ->

Uncheck the "Web Proxy" && "Secure Web Proxy" option

picture

0

After days of research I finally found the problem.

The mDNSResponder service wasn't running.

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponderHelper.plist
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.discoveryd.plist
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.discoveryd_helper.plist

More resources can be found here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .