1

My Left-Command key keeps bringing up the Mission Control.

I've gone through all the steps in Mac tip: How to restore your keyboard to its default settings to restore all keyboard mappings and shortcuts back to their defaults, but it hasn't fixed the problem.

In TextEditor, I type some text, highlight it, cut it to the clipboard by selecting "Cut <Command>C" from the menu.

If I select "Paste <Command>V" from the menu, the clipboard contents pastes successfully.

But if I try to paste the clipboard contents using the keyboard, by typing <Command>V, nothing pastes, and instead I see a listing of my work spaces appear across the top of the screen, with a '+' at the right.

This is what shows up when I press <Command>

Any ideas as to what I need to do to get the Command key to work properly?

Mission Control is supposed to be popping up when I press <Ctrl><Up-Arrow>, and that's not working, either.

Oddly enough, my Right-Command key works. That still leaves me with a real problem, because I need to VNC into this machine, and every VNC client I've tried only doesn't distinguish between left and right, they only send LeftC-Command.

1

OK, this one was just stupid.

In System Preferences ==> Mission Control, there is a section titled "Keyboard and Mouse Shortcuts". For each of "Mission Control", "Application Windows", "Show Desktop", and "Show Dashboard", there is a dropdown where you can select which keyboard shortcut you want to use.

This is separate from System Preferences ==> Keyboard ==> Shortcuts ==> Mission Control.

Mission Control

In my case, it showed that "Mission Control" was mapped to <Ctrl><Up-Arrow>.

I changed it to F1, then changed it back to <Ctrl><Up-Arrow>, and now it works. Apparently, it had been mapped to in a way that didn't update the GUI, and switching it to something different and then back fixed it.

I hate this kind of thing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .