11

Today I restarted my Mac after several weeks uptime. After restart, I got the login screen with unresponsive keyboard and mouse.

Right before this problem I had Aperture open, with a problematic library. I don't know if it's related, I just mention it. I have my Aperture photos on an external disk, which disconnected improperly because the cable disconnected. I tried to reopen Aperture, but it refused, and repairing the library failed several times. That was the time I decided to do a restart, after which this problem appeared. (Update: Aperture seems not related, as this problem has occured another time wihtout using Aperture.)

I have two accounts on this MacBook (early 2015 13" retina), so I see two icons for these accounts, with the names under it. Below that I see the following text:

If you're having a problem entering your password, press andOS. hold thepower buttn on your Mac to shut it down. Then press it agin to start up in the Recovery OS.

The touchpad is unresponsive (no movement at all), the keyboard doesn't work. I tried pressing TAB, cursor keys, and the first letter of my account name.

I tried a restart, after which the Mac started into recovery mode. I don't want that. I know the password, and I know that's not the problem. I've had this problem once before, about six weeks ago. Since then I've had some restarts. Back then I couldn't start for one day, and then suddenly it worked. I don't remember what I did to get it working. After that I did one or two restarts, which worked normally.

System information

  • macOS Sierra 10.12, latest updates
  • early 2015 Mactbook Pro Retina, 13"
  • Base Qi SD-card inserted, which is always connected
  • External harddisk was connected
  • All disk, including OS disk, are encrypted using FileVault

Situations

  1. When this happened I tried another boot, which showed a black screen with only the Apple logo on it, for 10 or 20 minutes. I just killed it, and noticed the laptop was very hot at the top of the keyboard, where the function keys are. Near the touchpad temperature is normal.
  2. I did another boot, and then I see the startup screen with the two accounts. The touchpad does not work, the mouse doesn't move. This is not a hardware problem.
  3. In recovery mode, the mouse and keyboard work OK.
  4. After several tries, I could select my account using the tab key. This means I press the key, nothing happens, I try again and then suddenly one account is selected. I did press the S key for the first letter of the username (S), so that might as well be the key that activated this. It's not responsive. I just press a key, wait ten seconds, press another key, hope to see something happen. Then suddenly I get the password field. Entering the pasword is problematic, but I'm going to try. When I start to enter my (long) password, it suddenly fils up with dots faster than I was typing. The password doesn't work, I tried several times.
  5. I press the power button to kill the machine. Several hours later I tried again. Now it works without a problem.

So while this means the problem is solved, I've had this situation twice now. After leaving the machine off for several hours, it seems to work. I haven't done anything to fix this, apart from leaving the machine of power for several hours. Power adapter was not attached. My gut feeling tells me that this might be a hardware problem, but I don't understand it.

Can anyone explain this behaviour?


Solutions

So far I've seen three "solutions" to this problem. See the comments!

  1. Connect a USB mouse or keyboard during login. You can disconnect after login. If an external drive is connected during login, disconnect it first.
  2. Disable Filevault.
  3. Fresh reinstall; user account can be kept as is, inclusing user library.

Update 1

This has happened a third time. Yesterday I shut down the Mac. Today I tried to boot, and this process repeats. I've tried many restarts. When the restore system boots, I can type and the mouse works. I can unlock the disks, so the password is OK. But I don't need to reset the password - I just proved that iw works. So I reboot, then again - no mouse, no keyboard.

Well, I can press the first letter of my username, and then after a long wait I see that user is selected. Then I can press enter, and I get the password field. I can press one key, wait until I see that one character is entered (one bullet), then press another key. Sometimes nothing happens, so I press the same key again, and after a while you have no idea what is entered and what not.


Update 2

I got it working again. I tried all this without the power adapter connected. After connecting and charging to a full 100% I could start up again. I don't know if it's related, and I'll try to reproduce it.


Update 3 - solution (for now)

Disabling FileVault seems to fix this problem immediately, within seconds. Then I can restart, login, and at that moment the disk still has to be decrypted, so that is not the problem.


Update 4 - warning

See Password incorrect after enabling FileVault

Don't re-enable FileVault after disabling it.

If you really want to do this, make a good backup first, possibly an image of the disk.


Update 5 - Fresh reinstall - it works for now

I did a fresh reinstall, with Filevault enabled, and it works again. This means the old system library is gone. I kept the user system library, copying it with the rest of the user account. I don't know how long it will last, but I know how to get things working again.


Update 6 - Seems like an issue (bug) involving Filevault and USB

Some comments suggest connecting a USB keyboard or mouse at login, which can be disconnected right after being logged in. One commenter said this only happened when an external drive was connected. Disconnecting it solved the problem for the moment. After connecting it, the problem reappeared. It seems like this is a bug that involves both USB and Filevault.

  • 1
    Have you tried running Apple Hardware Test (AHT)? Hold the D key while booting from a powered off state with the AC adapter connected. I would do this a few times since you seem to have an issue when the MB is up and running for a while. – Allan Dec 11 '16 at 13:48
  • 1
    Have you tried booting into safe mode when this happens? That will disable any extra kexts etc and clear/rebuild some stuff so might help, if it's a software issue. Anyways, to diagnose this properly you need to enable SSH and screen sharing and log in remotely when it happens. Check top, have a look in syslog, and see how the maschine responds to input coming over VNC... – tolgraven Dec 11 '16 at 21:43
  • 1
    @tolgraven, you can make your comment an answer. Then I can reward you the bounty points. You didn't solve the problem, but gave me a good suggestion and the points are lost otherwise. – SPRBRN Dec 16 '16 at 9:52
  • 1
    I have this issue for the 3rd time. Fixing it by connecting external keyboard & mouse, then reinstall macOS (not from time machine, clean install). Each time it happens after some time. The gap between the launches doesn't matter. Happens for me on MacbookPro early 2015. Does it happen to anyone on different hardware configuration? – Vive Mar 31 '17 at 17:05
  • 1
    @Elliott, you can enter recovery mode, and they the keyboard works normally. There you can disable filevault, then reboot into the decrypted machine. – SPRBRN Jun 27 '17 at 14:19
4

I had the exact same issue. For me this was an issue of FileVault.

Try disabling FileVault and see if it helps. Also by cleaning the NVRAM the next boot will be OK.

Judging from forum responses this is a known issue by Apple but no software update or hardware replacement program has been announced to my knowledge.

  • I just had this problem. This time it lasted too long, and I decided to try disabling Filevault, after which I could login immediately. The strange thing is that it didn't need to decrypt the disk. It took about two seconds, then I could restart, login, all works, and now it's decrypting the harddisk, which is not needed anymore. So did you encrypt the disk again afterwards? That's my intention, and then see what happens. – SPRBRN Jan 12 '17 at 19:33
  • Sometimes just clearing NVRAM is enough to fix this for me. Disabling FileVault isn't an option in my case. – Ian Dunn Jul 2 at 15:14
2

I installed Sierra today and faced the same problem. And yes the solution also worked which is disabling the file vault.

In case you are not able to (or facing difficulty) go pass the login screen, just plug in an external mouse and a keyboard. Fortunately, they work fine and this'll help you to go pass the login screen and fix the issue.

  • You mean that all works normal when using an external mouse? So you can login normally, then proceed to work without issues? I'm still without Filevault. When I have time on my hand, I'm going to try to do a new install, whipe the disk entirely and see if that helps. Knowing that disabling filevault is quite easy, I find it worth trying. – SPRBRN Mar 4 '17 at 15:58
  • Yeah, the mouse won't work that perfectly (will lag, a lot) but the keyboard does. You can type the password easily and then proceed. – hashcode55 Mar 4 '17 at 16:13
  • I saw this problem today on El Capitan. Plugging in an external keyboard did not work! I had to enter recovery mode before either keyboard would work. – James Oct 24 '17 at 17:01
  • My external keyboard didn't work either. Resetting the NVRAM (⌘⌥PR at boot) worked, though. – SilverWolf Oct 27 '17 at 15:07
2

I had a similar problem with macOS 10.12.6 on my 2017 iMac. The problem goes away when I disconnected an external USB hard drive (Sabrent enclosure) and returns when I reconnect the drive.

  • It seems like it's an issue between Filevault and USB. Others have mentioned that connecting a USB mouse or keyboard fixes the problem. Thanks for the feedback! – SPRBRN Sep 8 '17 at 18:21
  • I was able to fix it by disconnecting most of my USB devices, but leaving mouse/keyboard plugged directly into iMac (not through hub), and also resetting NVRAM. In the past resetting NVRAM was enough to fix it, but this time I had to also disconnect those devices. – Ian Dunn Jul 2 at 15:12
1
+50

Have you tried booting into safe mode when this happens? That will disable any extra kexts etc and clear/rebuild some stuff so might help, if it's a software issue.

Anyways, to diagnose this properly you need to enable SSH and screen sharing and log in remotely when it happens. Check top, have a look in syslog, and see how the maschine responds to input coming over VNC...

  • I just had this problem. After your comment I enabled SSH login, to be sure it worked. I could not login, and looking back, how should this have worked? The system is encrypted with Filevault. So after startup, a kind of pre-OS starts up to enable loggin in and unlocking the system. How would SSH or any other service work at this moment? Anyway, it turned out that disabling Filevault solved the problem. So I changed the accepted answer to that of @AMilassin. – SPRBRN Jan 12 '17 at 19:44
1

I get the same problem, with a message to restart in recovery mode, which seems a pain. What I actually do whenever this happens is to plug the magic keyboard into the mac as if recharging - and it works straight away. Once the normal desktop is up, it can be disconnected. Seems like an apple bug to me.

  • I did a fresh reinstall, and that fixed it for me. – SPRBRN Aug 23 '17 at 10:11
0

I have this problem with an Apple magic mouse (bluetooth) and a generic-ish USB keyboard connected to a 12/24 core "cheesegrater" mac pro under 10.12.6:

Reboot after ten days or so, then there's no mouse pointer, no keyboard.

Solution:

  • Unplug the mac pro from the AC supply
  • Wait one minute for system controller to reset
  • Plug back in
  • Power up using button on front of Mac Pro
  • Machine comes up normally
  • Log in, mouse and keyboard working fine

I hesitate to call this a "solution", but it's at least a consistently working hack for me.

PS: I'm not using filevault.

-3

Why not start in the RecoveyPartition. Choose DiskUtility from the Utilities menu, click the FirstAid tab in the latest Sierra it will check and repair disk permissions.

  • 2
    No it won't. Stop posting guesses as answers. – Tetsujin Dec 11 '16 at 16:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .