0

So, I had a panic an hour or so ago because randomly my Macbook Pro 2011 screen decided to display flickering green on black pixels.

This looked quite bad on my desktop as it has so many dark colours:

Macbook

After a frantic Google and Stack search, I found THIS that basically says to open up the Macbook, disconnect the screen cable, clean it with a can of air and reconnect.

I did this twice, but it didn't work for the most part.

I then went on to find THIS on this exchange, that suggests the first port of call is to disable "Automatic Graphics Switching" before trying anything else.

Automatic Graphics Switching

So that's what I did... I think...

I actually went into the Energy Preferences and ticked the box, so it looks like the image above...

It's worth mentioning, (and something I've only just realised), at the time, I had a couple of web browsers open, one with youtube playing, just as I opened a Word doc in Microsoft Word! I believe this is around when It happened. (Although I had just moved the Laptop back from another desk as I was cleaning too), Possible irrelevant but worth noting.

Anyway, could Word opening have caused the Macbook to enable/disable graphics switching some how?

So basically, my questions are, firstly, does it mean I've just enabled or disabled Automatic Graphics Switching? Secondly, why are the dark pixels flickering green? And thirdly, has it fixed the problem, or is there still a hardware problem somewhere?

1

This is related to the AMD Radeon discrete graphics card. It is a hardware issue.

I noticed it come up when plugging in an external monitor on my 2011 MacBook Pro 15" (as it forces the discrete graphics to be used at that time).

The only band-aid fix I was able to find was to force the use of the Intel integrated graphics over the AMD Radeon graphics card. I found a handy utility called GfxCardStatus to both show you what graphics card is in use, and also toggle the use of the Intel integrated graphics card. The utility is available at http://gfx.io

Unfortunately for me in my case, you can't use the integrated graphics card with an external display attached. But at least it gets rid of the green dots in some cases.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .