0

I have an iphone 6 updated to ios 10.1.1 (14b100).

A short while ago, the calendar app would open on the button click, but not allow me to add anything to it. I realised it was just responding very, very slowly but it doesn't give me notifications or sync with my ical on my mac.

During this time, I got a replacement iphone as my screen was broken, saved the old data from my iphone and put it on the new iphone. This did not fix the problem. It's driving me nuts!

Also, going into settings on the phone and accessing the calendar settings is very, very slow and crashes out half the time (or kicks me back to the main iphone dashboard). I have tried looking in diagnostics&usage/data to see if there are any crashed but can't find anything useful in there to indicate that there is a dodgy event in the calendar.

After deleting all my email accounts from my phone, nothing had improved. I decided to try installing google calendar. Some progress: It loaded and then had a spinning wheel in the centre (what I presume is a loading sign) and then crashed out. I re-loaded it and clicked the plus icon to add accounts; it added my gmail account but when i tried to add my work gmail account (which is through a domain) it hung and then kicked me out.

I'm at my wits' end! Any help much appreciated.

1

You said you got a replacement because the screen was broken - can I assume that Apple replaced it? If so, did you ask them about the calendar?

In any case, I would try the following:

  1. Perform a full backup.
  2. Perform an iPhone factory reset
  3. Test your calendars and see if it's still slow. If it is, then it's a problem with the phone. If not, then try restoring from your back and see if the problem persists.
  • It was through my insurance company so not through apple. Will give you suggestion a go - thank you. – William Leigh Nov 30 '16 at 9:47
  • through your insurance company? they did the work? or they sent it somewhere to be repaired? – Zonker.in.Geneva Nov 30 '16 at 23:34
  • It was a replacement handset. – William Leigh Dec 7 '16 at 20:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .