0

I have a MacBook Pro (Retina, 13-inch, Late 2013) and an iPad 4. The iPad is freshly installed.

Problem

Whenever I plug it into the left or right USB port of my MacBook, it connects for a fraction of a second (the power indicator on the iPad turns green and iTunes opens), but then it disconnects again. This goes on and on, re-connecting every few seconds.

There's a video of the behavior here:

What I've tried

  • When I plug it into the Apple keyboard's ports, it is not charging, but now the connection is stable. iTunes also recognizes it properly now.
  • I've already tried it on another Windows PC, where it works fine. Also, I've tried using another cable – no dice.
  • Restarting the Mac and the iPad

Other info

Here's what the System Profiler has to say about the MacBook with no peripherals connected:

Is it the internal memory card reader that drains all the required power? But why?

What could I do to make this behavior stop?

  • I have the exact same issue with an iPad Air 2 and a 2015 Macbook Pro running the latest MacOs Sierra (10.12.6) right now. I had my iPad repaired and they couldn't recreate the problem but they replaced the iPad anyway. When I came back home, the disconnection was still there so I figured it was a Macbook issue. So frustrating because my Mac's warranty just expired a month ago. So frustrating. – eric Sep 8 '17 at 19:33
  • I also think it's the Mac which can't supply enough power – still haven't been able to troubleshoot it. And of course, no warranty. – slhck Sep 9 '17 at 14:15
2

After a broad search, I found this solution which worked for me:

On the iPad tap Settings > General > Reset > Reset Location & Privacy. This will reset your location and privacy settings and require you to set up a trust relationship with the PC/laptop again.

But if you are running out of options ... try that and see if it works. I realize this thread is older, but posting this solution here in case it helps other people.

  • This worked for me too, reset privacy and re-trust. Thanks. I met the OP problem after I did a default factory reset of my iPad mini 4, logged in with another Apple ID and changed its device name to a new one from iTunes. – gpanda Apr 4 '18 at 10:03
0

This question has a number of helpful answers. In my case, force-quitting the usbd service did the trick. Launch the "Activity Monitor" > select the usbd process > click on the cross in the top left corner > select "Force Quit".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .