When running the Upgrade Installer from VMware Fusion 3.1.3 to v4.0.1, this dialog pops up:

A virtual machine is running with an older version of VMware Fusion.

Please use the older version of VMware Fusion to suspend or power off all virtual machines.

I shut down all the guests, reran the installer, same thing. I used vmware article 1017838 to uninstall v3 manually, reboot, and then drag the Fusion 4 app to the Applications folder. Reboot and run Fusion. Same thing. Checked /var/run for vmware items. Checked Activity Monitor for vmware items. Rechecked locations specified in 1017838 and used spotlight to search around.

I moved all my guests to an extra drive and unmounted that drive, and repeated the uninstall and reinstall. A friend recommended an app called "CleanApp" to watch what files are created and modified during the installs, which did reveal a bit more cruft. Basically, I've tried to scrub my system of all things Fusion, both versions including guests, and then done a reinstall, and that hasn't worked. My last gasp was booting into the 32 bit kernel but that didn't help.

I've filed a ticket with VMware, but it's been a slow slog.

  • It is not immediate obvious to me in your description above, but did you run the uninstall from 3.1.3? I see that you manually removed it, but what about running the uninstaller?
    – EmmEff
    Sep 29, 2011 at 15:52
  • I've attempted to clarify the question based on your comment and TheWellington's point about simply dragging the app icon to the Application Folder. I've done it both ways. First time, I ran the Upgrade 'installer' in the dmg. The first step of that is to trigger a uninstaller. When I got stuck there, I found 1017838 whose first step is to run the uninstall app found in 3.1.3. The stand alone 3.1.3 uninstaller also reports the same error.
    – Paul P
    Sep 30, 2011 at 2:09

3 Answers 3


You can try with this command from a Terminal:

VMware 3.x

/Library/Application\ Support/VMware\ Fusion/vmrun list

VMware 4.x

/Applications/VMware\ Fusion.app/Contents/Library/vmrun list

to see if you have any VMs runnig - if you do, then run this command:

VMware 3.x

/Library/Application\ Support/VMware\ Fusion/vmrun -T fusion stop "/path/to/.vmx" hard

VMware 4.x

/Applications/VMware\ Fusion.app/Contents/Library/vmrun -T fusion stop "/path/to/.vmx" hard

where you replace "/path/to/.vmx" with your path to the VM still running.


Fusion uses lock files to prevent multiple processes from modifying the same files at the same time, as could happen if you tried to run to copies of Fusion (say version 3 and version 4) at once. When Fusion quits abnormally it leaves behind the lock files and you need to clean them up manually.

See this support article for how to check for running VMs and clean up Fusion lock files. If that doesn't solve it, do a Spotlight search including system files for files whose names end in .lck and if they look like they belong to Fusion, delete them. You may find some lurking in your user home directory.


As I recall, the .dmg that contains the vmware installer contained several items... one was a drag & drop VMware install. You know the kind, drag to applications and be done.

One of the other items, that I had to scroll to find (love the invisible scrollbars in Lion) was an installer .pkg file that simultaneously uninstalled Fusion 3, and installed Fusion 4. I don't recall what it was called. Have you tried this .pkg?

I ask because you refer to two steps, and I distinctly recall only one step to do the upgrade. I ran the .pkg and Fusion 3 was removed and 4 was installed. I didn't need to take any additional steps.

It may be too late to try that method now, with all that you have done to remove Fusion 3... but give it a try.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .