2

I am manually transferring some files using SMB over my local network to a new MacBook Pro from an old one (mid-2012) via WiFi, and the old MBP appears to be the bottleneck, with its Data sent/sec rate averaging ~3 MB/sec.

The WiFi router is rated AC3200, and I ran a download test to each laptop from a Gigabit Ethernet-connected NAS (isolating WiFi download), and they could both achieve 20-30 MB/sec download. On the sending computer, I copied a large file to Dropbox, and the total Data Sent rate jumped from ~3 MB/sec to ~18 MB/sec, so it appears the problem is specific to the SMB transfer, not that computer's WiFi connection.

Why wouldn't an SMB transfer go faster, since there is clearly headroom for upload in the sending computer and similarly download headroom of the receiving one?

1

Looks like the issue is with SMB client signing. Try disabling it and see if your transfer speeds improve.
To do this open Terminal.app (search with Spotlight or go to Applications/Utilities)
Enter this command: sudo nano /etc/nsmb.conf
Add these lines to that file:
[default] signing_required=no
Ctrl + X to exit the editor, Y to save the file name, Enter to confirm.
Unmount and remount the SMB share and test the transfer speed.

  • 1
    FYI I put the config in ~/Library/Preferences and it worked the same. What risks are there when running SMB with client signing disabled? – wst Nov 28 '16 at 21:54
  • 1
    With client signing disabled you run the risk of a "man in the middle" attack where a malicious user could alter the data being transferred. If SMB is being used just in your internal network and that is secure it's a minimal risk. – Snacking_IT Nov 28 '16 at 22:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .