My daughter's Mac failed to boot. I did the following:

  1. Recovery Mode - would not allow me to reinstall OS X; Disk Utility failed.

  2. Internet Recovery Mode - didn’t work.

  3. Created external drive with OS X, rebooted successfully from it.

  4. Tried everything "standard", not working, Repair fails.

  5. Erased HDD (worked); the rest was no change, tried again Disk Utility etc. with no results.

  6. Terminal attempts:

     diskutil verifyvolume disk0s2
     The volume could not be verified completely. File system check exit code is 8.
     diskutil repairvolume disk0s2
     The volume could not be verified completely. File system check exit code is 8.

fsck #1

fsck attempt 1

fsck #2

fsck attempt 2

Computer specs: MacBookPro7,1; HDD 500GB, model: WDC WD5000BPKT-00PK4T0 -

And now...I am finally short of ideas. Any advice from the community, please?

  • 1
    I'd suspect the SATA cable to be faulty - which is pretty common for a number of different MacBook Pro models; your daughter's included.
    – klanomath
    Commented Nov 28, 2016 at 14:21

1 Answer 1


The error File system check exit code is 8 indicates you have an unrecoverable file system read error.

This can be due to either or both of the following:

  • Corrupted file system
  • Failing/failed hardware

If it's a just a file system problem, you can try the following:

  • run First Aid multiple times to see if the problem gets fixed
  • wipe your drive (format it) and reinstall macOS

Obviously, if the first option doesn't fix the problem, your next option is to format and reinstall.

If it's a hardware issue, your best bet would be to replace the failing drive with a new one. Your MacBook Pro (MacBookPro7,1) is a Mid-2010 model which means it's a 7 year old drive (if it hasn't been replaced) which is well beyond the lifespan of spinning hard drives. At this point, I would recommend upgrading to an SSD and even maxing out the memory for best performance.

While I agree with @klanomath that it could be the SATA cable, it's not the most likely culprit given the age of the laptop and drive. My money is on a failed hard drive. However, a replacement SATA cable is fairly inexpensive part and if you decide to go that route, it won't be an expensive investment.

  • Hi Allan and @klanomath, thanks for your suggestions. A couple more hints: First Aid always fails. Erasing HDD works. Installing OS X to HDD does not work (installation process always freezes). I can only boot from external drive. What is interesting: HDD appears to be completely full (after erasing and formatting), that is strange. Any more suggestions how to figure out if the issue is file system, failed HDD or just SATA cable, please?
    – scubafreak
    Commented Nov 29, 2016 at 1:56
  • If it's the cable it will fail "everywhere" on the drive, not just in certain parts. Try doing a secure erase and see if there are problems. Also, just for grins and giggles, issue the command diskutil info /dev/disk0 | grep -i smart and post the result. Also, try running Apple Hardware Test (AHT). Hold the D key while booting from a powered off state with the AC adapter connected.
    – Allan
    Commented Nov 29, 2016 at 2:06
  • SMART status: Verified.
    – scubafreak
    Commented Nov 29, 2016 at 4:30
  • AHT could not be initiated. After a couple of format/reformat attempts... has to go for the hardware check, I guess
    – scubafreak
    Commented Dec 4, 2016 at 4:02
  • I am still leaning towards a failed disk. If you swap it out with a new one, the problem should go away.
    – Allan
    Commented Dec 8, 2016 at 19:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .