0

I am using iTunes on OS X El Capitan. I have a CD with songs on it and I would like to import these into the iTunes library (the local one, not the cloud). For the option in preferences, I have it set to "Ask to import CD", but the dialogue for that does not show up. Is there some way to MAKE it import the songs without having to wait for a dialogue to pop up? Like maybe something in the menu bar that says "Import songs from CD"?

Update: And now, when iTunes is running, the CD/DVD is being ejected right after being inserted.

1

Assuming that the CD shows up fine on your computer, you should be able to manually start the import process by opening iTunes and going to: File > Add to Library

In the file dialog that opens, you should see your CD listed on the left side under "Devices". Click this, select all songs, and click "Open" to import the songs.

Also:
To try and clarify what the other answer says, when a CD is inserted, a CD icon usually appears in the upper left hand corner of the main iTunes window. Clicking or right-clicking on this should give some import options.

  • Does that achieve the same effect as it automatically importing it? – Melab Dec 2 '16 at 20:19
  • Yes - there's no reason it wouldn't be. It's the same import function, just called with a button click instead of an automated task. – Testing Dec 5 '16 at 17:21
0

When the CD appears into iTunes as the CD that it is, doesn't right-clicking the songs reveal a "Create mp3 version" action in the menu that appears?

  • Is that the same as an import? – Melab Dec 2 '16 at 19:50
  • Yes. I don't think I've ever even done it otherwise. What do you want them as? AAC, AIFF, MP3, WAV? If you go to iTunes preferences > general > CD import settings, that's where you specify which format to import CDs as. If you choose mp3, then right-click on any song, the sub-menu will contain the action "Create mp3 version". However, if you choose some other format in the import settings, for example, WAV, then right-clicking a song will have "Create wav version" in the menu instead. – user158589 Dec 3 '16 at 21:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .