0

This question already has an answer here:

I'm trying to enable macOS El Capitan's built in read/write support for NTFS, but it doesn't seem to be working. First of all; I'm aware it's not the fastest, and no officially supported, but my needs for it aren't critical (nor the data super important, it's just games).

Anyway, I've followed the usual guides to enabling support, and my /etc/fstab looks like:

UUID=E2E3FA2C-5B6D-4510-B4F6-E370A09B0AF6       none    ntfs    rw,auto,nobrowse

However, when attempting to mount the drive with diskutil mount disk0s9 I get the following error:

Volume on disk0s9 failed to mount
If the volume is damaged, try the "readOnly" option

If I remove the fstab entry the volume mounts just fine in read-only mode, and under Windows I can confirm that it is undamaged. It's strange as this is the exact method I've used successfully in the past (not with the same partition though).

Here's the diskutil info output for the partition:

Device Identifier:        disk0s9
Device Node:              /dev/disk0s9
Whole:                    No
Part of Whole:            disk0
Device / Media Name:      Windows_NTFS_Untitled_2

Volume Name:              Games

Mounted:                  No

File System Personality:  NTFS
Type (Bundle):            ntfs
Name (User Visible):      Windows NT File System (NTFS)

Partition Type:           Microsoft Basic Data
OS Can Be Installed:      No
Media Type:               Generic
Protocol:                 SATA
SMART Status:             Verified
Volume UUID:              E2E3FA2C-5B6D-4510-B4F6-E370A09B0AF6
Disk / Partition UUID:    0C407B03-62D7-4C64-BC5C-3C57668C2F2E

Total Size:               249.2 GB (249152208896 Bytes) (exactly 486625408 512-Byte-Units)
Volume Free Space:        0 B (0 Bytes) (exactly 0 512-Byte-Units)
Device Block Size:        512 Bytes

Read-Only Media:          No
Read-Only Volume:         Not applicable (not mounted)

Device Location:          Internal
Removable Media:          No

Solid State:              Yes

In case it may be relevant; the partition was formatted natively by Windows 10.

The only suspicious thing to me is the device/media name of Windows_NTFS_Untitled_2, whereas for a Windows OS partition it is 'Basic data partition', but I'm sure that's important.

Any ideas why this isn't mounting in read/write mode? I had hoped to use built-in support to avoid having to install FUSE etc., which I assume still involves disabling system integrity protection?

Duplicate

This issue is not a duplicate as proposed; the other issue only asks how to enable read/write, however I already know how I'm supposed to be able to do it using the built-in driver, but am unable to do-so. In other words this question is asking why setting the rw option in /etc/fstab no longer appears to work (and how it can be fixed), rather than how can I get read/write support in the first place.

It is absolutely not an exact duplicate of the proposed original.

marked as duplicate by nohillside Nov 27 '16 at 13:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • As builtin writing is not supported perhaps Apple just broke it . It would make sense for an unsupported thing to be fully switched off instead of letting people hit known bugs – Mark Nov 27 '16 at 12:29
  • Just because it's unsupported doesn't mean it's actually buggy in the normal sense; I've used this in the past without complaint at all, because I don't need serious performance or multi-threaded access, just the ability to move files now and then. The built-in read/write support's main drawbacks are that it's slow, and unstable when pushed hard or unmounted unexpectedly. – Haravikk Dec 4 '16 at 18:13
-3

afaik (ntfs) writing is not supported in osx and macos. use a ntfs driver, check its compatibility for your os.

Not the answer you're looking for? Browse other questions tagged .