I'm attempting to either restore or update an iPhone 5 which won't boot. It's stuck on the apple logo boot screen. Hard reset does nothing.

I have tried normal restore mode via iTunes and DFU mode.

I'm signed into iTunes as the same apple ID as the phone.

I've authorized the mac for this apple ID in iTunes.

each time I try and either do update or restore I get the following error from iTunes:

iphone could not be restored (updated). TATSU declined to authorize this image on this device for this user.

Anything else I can try? it does not matter if I lose the data on the phone. Just needs to work again.

Also is there a way to view the boot sequence from my mac or the phone either via terminal or xcode or something so I can see where it's hanging in the boot sequence?

2 Answers 2


for anyone else who comes across this or something similar. It turned out that my hosts file had an entry to gs.apple.com which was causing apple's signing (TATSU) server request to fail with their not so helpful error message.

So you need to check your hosts file on the computer you are running iTunes on to see if there are any entries to gs.apple.com and then either remove those lines or comment them out by placing a # at the start of the line.

like so #gs.apple.com 74.454.656.343 easiest way is via terminal. look up how to edit host file if you don't know how. on my mac the host file was located at /etc/hosts once in terminal: sudo nano /etc/hosts will open an editor, once changed control x will exit, type y then enter when prompted to save your changes to the hosts file. all done.

  • 4
    I checked my hosts file and does not have gs.apple.com entry... Is there any other ways to solve this?
    – DShah
    Dec 19, 2016 at 10:10
  • check what the exact error code is you are getting back from TATSU
    – njorlsaga
    Dec 27, 2016 at 17:56
  • nope. No gs.apple in hosts. I tried to disconnect the computer from the network to circumvent the TATSU error, but I got the -1 error from iTunes instead.
    – Emanuela
    Mar 27, 2018 at 3:10


If you're using a Mac, follow these steps:

  1. In the Finder, choose Applications > Utilities.

  2. Open Terminal.

  3. Type this command and press Return:

sudo nano /private/etc/hosts

  1. Enter the password you use to sign in to your computer and press Return. >You won't see text appear in the Terminal window when you type your >password.

  2. Terminal displays the hosts file. If you don't see a window similar to the one below, make sure you're using a nonblank administrator password.

  3. Navigate using the arrow keys and look for an entry containing >“gs.apple.com”.

If you don't see any entry containing gs.apple.com, then the hosts file >isn't related to the issue. Close the Terminal and move on to the next >section of this article, "Address TCP/IP filtering, firewall, or security >software."

  1. Add the # symbol and a space ("# ") to the beginning of the gs.apple.com >entry.

  2. Press Control-O to save the file.

  3. Press Return when asked for the filename.

  4. Press Control-X to exit the editor.

  5. Restart your Mac.

After your computer is finished restarting, try to update or restore your >iOS device again.


That being said, there is no such entry in my /private/etc/hosts or in my /etc/hosts file, so I will look for other solutions to this error.

  • Not seeing it. Where is it exactly? Feb 6, 2018 at 23:18
  • 1
    I posted the official Apple support instructions, but as I mentioned above, "there is no such entry in my /private/etc/hosts or in my /etc/hosts file" . My intent was to provide a starting point for users with the same issue.
    – Ron K.
    Mar 1, 2018 at 15:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .