1

I am using 10.9 with Server app 3, and right now i am using an obsolete connection with TLS 1.0, RSA and AES_128CBC with HMAC-SHA1 (that cames by default).

While i was trying to upgrade openssl, i notice that when i tried to upgrade it says that openssl is not installed but it is.

remote:~ root# port upgrade openssl
Error: openssl is not installed
remote:~ root# openssl version
OpenSSL 0.9.8zg 14 July 2015

So i would like to know how can i upgrade it, and why is not being detected as installed?

3

OpenSSL 0.9.8zg 14 July 2015 is the version installed by OS X 10.9(.5) (Mavericks) and resides in /usr/bin/.

MacPorts neither installs nor updates/upgrades genuine Apple (OK, OpenSSL is not Apple but it's part of their basic BSD package) system software. MacPorts' standard realm is /opt/...

You would have to install a newer OpenSSL version with MacPorts - if available.

  • Thanks for the response klanomath! I have tried to install openssl through mac ports but now i am having an issue with linking to new openssl from macports instead of the old one who came with OS X. It simply doesnt link. I have done dorlandode answer here and nothing (i dont have dotnet in this system so didnt run that last line): github.com/Homebrew/brew/pull/597 – SipriusPT Nov 25 '16 at 10:50
  • @SipriusPT dorlandode's answer (or receipt) is (or works) for the homebrew (also a OS X package manager) installed openssl only. You have to search in a MacPorts forum for a proper answer how to link openssl libs. – klanomath Nov 25 '16 at 10:55
  • Ah i yes my mistake i said mac ports instead of brew. I will do that. Thanks again! – SipriusPT Nov 25 '16 at 11:04

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.