6

After installing Windows 10 with Boot Camp Assistant for my Late-2016 15" MacBook Pro, I'm finding maximum volume to be almost inaudibly quiet under nearly all uses. The audio is deafeningly loud at full volume under macOS, so something is definitely wrong

Windows shows the volume is maxed. Nothing obvious in control panel. The driver is apparently "Cirrius", but I know nothing about it.

Searching around yields a lot of similar complaints from 2009, and advice to install Realtek drivers, but that's so out of date I don't suspect I should risk it. Any ideas?

2
  • I have the same problem. On macos volume is fantastic but on windows 10 very low. Have you solved this already? Commented Dec 28, 2016 at 19:55
  • sorry, no luck! Commented Dec 29, 2016 at 21:23

15 Answers 15

5

I have the same problem on a MacBook Air with the Cirrius drivers. I managed to get the volume to boost a little by checking the "disable all enhancements" box on the sound properties (as some online had suggested from a few years back), but still no where near as load as it gets on a Mac. It is certainly a driver issue but so far I've yet to find a fixed driver.

2
  • 1
    That actually worked. I don't know who downvoted this. +1 for valid answer.
    – blez
    Commented Jan 17, 2017 at 20:48
  • I found that enabling Loudness Equalisation actually fixed the problem for me, of course this answer is quite old and Windows 10 is a moving target, I'd suggest trying them all out and seeing if that helps.
    – Dean Smith
    Commented Aug 16, 2020 at 9:25
3

I had this issue... Solved by booting into MacOS and turning volume all the way up... then plug in headphones and turn volume all the way up... It was set to like %10 volume.

The windows driver doesn't access the chip's volume properly.

1
  • This worked for me. It seems 100% for Windows is whatever level macOS is currently set to. Commented Jul 3, 2020 at 2:38
2

I did everything listed above and none worked.

This one did the trick.

In windows 10:

  1. Right click the volume icon in the task tray, and choose Open Volume Mixer.
  2. Click device speakers
  3. Spatial Sound
  4. Windows Sonic for headphones.

I dont know why but now my imac with windows 10 has max volume.

1

I experienced this problem the last few days in Windows 10 (using Bootcamp) on my 15" MacBook Pro when playing videos through the built in speakers. To fix it, this worked for me:

  1. Right click the volume icon in the task tray, and choose Open Sound Settings.
  2. Scroll down to Related Settings and click on Sound control panel.
  3. Scroll down and select Speakers, and then click Configure.
  4. Change Quadraphonic to Stereo and back to Quadraphonic again.
    (I actually Tested the sound for Stereo before changing it back again, but not sure if that's required).
  5. Hit Test and the sound should come blaring out!
  6. Hit Next, then Next again, and then Finish to end the wizard leaving the defaults in place.
  7. Click Ok in the Sound control panel window.

You're hopefully working now!

1

Just go to Device manager (Right click on This PC > Manage, Expand sound, video and game controllers, Find Cirrus Logic drive, go to Properties, Disable this driver, then restart PC, and after that go to the device manager again and Enable this driver. It helped for me and now volume is back to normal.

1

I had the same problem in my MacBook Pro (Mid 2010) running Windows 10 64bit.

The sound worked installing the CirrusDriver4206x64 on the folder Drivers/Apple/ of Boot Camp downloaded with Brigadier.

But the sound was low in comparision with MacOS. So, I did the steps above, and in the last tab named "Spatial Sound" I disabled it.

Now the sound seens like in the MacOS.

1
  • Firstly, welcome to Ask Different! :) I hope you come to find this site has a lot to offer! In case you haven't already, it's worth taking the time to read the tour. As for your answer, can you edit it to clarify which "steps above" you're referring to? There's a number of other answers and the order of answers can change over time.
    – Monomeeth
    Commented Aug 7, 2019 at 7:54
1

I also had this issue until I looked into the Speakers Properties > Advanced tab and saw that it was set to a 24 bit quality, changed it to my macOS default (32 bit 44100Hz) and it ran just like on macOS

0

I installed win 10 on a dell optiplex, low sound on headphones, tried all the adjustments, (another dell was OK though, it can be individual PCs), anyway I solved it by using a usb sound card from ebay £ 3 -4, it has mike and headphone jacks, and sound is back to normal...it might also work if you got usb headphones but not tried yet...

0

Here's what I did~

Playback Devices -> Cirrus Logic CS4208 -> Properties

Tab: Levels - Make sure they are at 100.

Tab: Enhancements - Turn on Loudness Equalization then open settings for that option and set the release to long.

This made Netflix max volume substantially louder.

0

I solved it.

  1. Right click the volume icon in the task tray, and choose Open Sound Settings.
  2. Under Cirrus click on "device properties"
  3. Click on Enhancements
  4. Check on low frequency, Speaker fill, loudness equalization

Solved!

0

This has nothing to do with the Driver. You simply go back into MacOS and you will find that your volume was low or not set to full. This limits the volume in windows to whatever the volume was in MacOS.

Fix. Go back into MacOS. Set Volume to 100. Restart and go into windows. 100 volume in windows is now the same as 100 volume in MacOS.

0

SOLVED. Set Loudness Equalization to Short. Here's how -

Go to speaker settings. Select 'Enhancements' tab.

Check 'Bass Boost' AND 'Loudness Equalization'.

The most important part, with Loudness Equalization selected, click on the Settings button just below it. Then change release time to 'Short'. BAM! That last step makes it as loud as the Mac. At laaaaaaaaaaaaast!

Image below shows it as well.

enter image description here

0

Updated Answer - 2022-08 For Macbooks from 2016 to 2019

New answer:

It seems to be fixed after the latest driver update from apple, now the sound is pretty good!

OLD answer:

Notes: You are not going to get the same audio quality on windows as macOS!

For Windows 10,

First, make sure the internal speaker volume and headphone volumes are set to 100% by booting into macOS. then reboot back to Windows

Then, Fix sound settings from the control panel

Part 1:

  • Right click the sound icon on the taskbar > "playback" tab > right click cirrus logic speakers > Configure Speakers

  • Select Quadrophonic > select both speaker sets as full range > finish

Part 2:

  • Right-click the sound icon on the taskbar > "playback" tab > right click cirrus logic speakers > Properties > enhancements

The recommended setting by me is to disable all enhancements, but you can play around and see what fits you

  • Bass Management - Don't bother

  • Speaker Fill - gives a nice boost to highs through the tweeters, Drawback are that some audio can give a weird hitch.

  • Room correction - Don't bother

  • Loudness Eq - it basically gives the average volume out of the loudest and the lowest sound / boosts the lower sound and reduces the higher sound till it comes close. I find it Good for movies, Drawbacks are that it will reduce audio instead of increasing it for some situations. Not good for music.

  • Spatial sound - didn't work on mine, I don't know.

Explanation

first and most obvious issue - Unlike on macOS where the setup is treated as a 2.2 Channel, it's treated as a 4 channel (we selected "Quadrophonic", if you selected stereo it will give a 2.0 Channel).

in macOS, the lows and low-mids are divided well towards the subwoofer while the highs and high-mids are played through the tweeters.

in Windows, the highs, mids, and lows are played through the subwoofer. while the tweeters give a light high sound (because it can't produce low sounds)

The reason for this is half-baked drivers from apple. (no surprise there) There's nothing we can do about this, at least for now. if you find an alternative driver, please let us know!

Based On Macbook Pro 15" 2016

0

Hey guys, ABSOLUTE FIX for LOW VOLUME audio with 2017 MacBook Air running bootcamp, Windows 11! (thanks God)

(If your machine isn't a MacBookr Air 2017, go to the end of the post)

  • The thing is, "disable all enhancements" infact gives you a higher volume and I recommend you doing that. (only with Apple lmao, any other Windows machine, Loudness Equalization at "long" gives you higher volume)

  • Every Apple model seems to react a little different, as some Mac Mini or MacBook Pro users said to have better results disabling/enabling spatial sound, changing audio bitrate and Hz to something greater like 32 bit 44100Hz, etc etc, which on my MacBook Air 2017 didn't make any difference, in opposition to those users, unfortunately.

That's a driver issue, as Apple prefers us using MacOS. Buuuuut, I managed to found two newer drivers that completely worked for me.

I installed Windows 11 the proper way, with BootCamp Assistant. The Cirrus Logic CS4208 (AB 126) driver version BootCamp installed was either 6.60001.3.24 (2015) or 6.60001.3.36 (2016) (I don't remember which), which are the versions with really low volume.

Also, check for the Hardware Ids before doing this, mine are HDAUDIO\FUNC_01&VEN_1013&DEV_4208&SUBSYS_106B7E00 HDAUDIO\FUNC_01&VEN_1013&DEV_4208&SUBSYS_106B7E00&REV_1003

The new drivers are:

Cirrus Logic CS4208 Version: 6.6001.3.39 [3/22/2017] https://dl.driverpack.io/driverpacks/repack/Sound_Others/CirrusLogic/FORCED/10x64/HDA_6.6001.4.07/CirrusLogic-FORCED-10x64-HDA_6.6001.4.07-drp.zip

Cirrus Logic CS4208 Version: 6.6001.4.2 [1/10/2018] https://statics.cirrus.com/pubs/software/LogoedDriverPackage-01-15-2018-6.6001.4.02.zip

The thing is, I'm actually not sure if there are any noticeable differences between the 2017 or 2018 one, but either of them managed to fix my low volume problem.

KEEP LOUDNESS EQUALIZATION DISABLED


If yours isn't a MacBook Air 2017, I suggest you also trying what I did: search for the driver the smart way

  • Go to your Device Manager and go down there to Sound, video and game controllers. There is where your audio controller device should be. It may be "Cirrus Logic [...]" or a "Apple Audio [..]" or something for its name.

enter image description here

  • Right click and go to properties. At the details tab, go to the Property box and select Hardware Ids. Right Click at the longest one and select copy.

enter image description here

  • Then, Google it.

enter image description here

  • The two sites that will most likely appear will be driverpack or driveridentifier. Try both. Also, be aware cause they will try to make you download their Driver Updater Software, but you don't need it. Simply download the .zip file.

  • Also, once in the page, try cntr+f and then cntrl+v, then you will search for your exact Hardware Id inside the page. If it found it in the page (the longest hardware id), that's a very good sign, but if it only found the shorter hardware Id, it also might work, but also not. Also, look to the driver version, you wouldn't want to download a previous version of your current driver, right? (in this case here)

  • If you are at Driver Pack,

enter image description here

  • If at Driver Identifier,

enter image description here

enter image description here

  • Then, extract the files.

(I can't upload more images)

  • Go back to Device Manager, go to your device, right click and update. Select Browse my computer for drivers -> Let me pick from a list of available drivers on my computer. Then, the button Have Disk.... Go to the folder you just extracted and select the .inf file. As we are talking about Apple, if the check box "Show compatible hardware" is checked and nothing is appearing, even if you uncheck the box and install one that seems that could work, probably won't, abort and try googling again. If one option appear, great, click next. Then click close. It probably won't need a reboot to work, mine didn't for this, but it is always good to reboot/restart.

  • IF IT DOESN'T HAVE ANY SOUND AFTER THE UPDATE: don't worry, Microsoft got your back bro. Go again to Device Manager, your device, right click, properties and the Driver tab. Select the middle option, Roll Back Driver. It will go to the previous driver that was installed, and that had sound.

I hope that helps!

-1

I have recently loaded windows 10 latest version on my MAC BOOK AIR 2018 Trust me its running like charm not even a single issue . 1 issue was low speaker volume . But i figured out the problem and got a best solution Follow Steps Below - 1) Open Control Panel 2) Go to sounds 3) In Playback Right Cick Speakers 4) Go to Properties and then to Enhancements 5) Disable all the enhancement 6) Apply and Enjoy

1
  • 1
    How is this answer any different then this previous one? Your answer is exactly the same. By doing this you risk downvotes.
    – fsb
    Commented Sep 12, 2019 at 19:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .