1

I have my Raspberry Pi setup as a WiFi router, which works great! Except for one problem, my MacBook.

Connecting through my Galaxy Tab 3 Note? A-OK. Alcatel cellphone? A-OK. Chromebook? Sure thing.

Even my Roku 2, no problem.

But my MacBook? It connects to the WiFi no problem. I can even run a python -m SimpleHTTPServer on it and connect to the server via http://172.16.1.1:8000 and that works just fine. But if I try to ping 8.8.8.8? Well, that's where we start running into issues.

I actually tried running tcpdump on my Raspberry when I started pinging 8.8.8.8 from my MacBook, but none of the ping packets showed up. I just tried pinging from a different device and packets definitely showed up.

There definitely was traffic from the Mac - a lot of UDP traffic, some TCP. Most of the TCP packets from my MacBook were retransmissions. There were some packets that were routed back to the IP. Here are a couple of the IPs:

UDP:

  • 65.55.223.48,21,17
  • 64.4.23.170,148,142
  • 50.242.151.22
  • 37.59.40.88
  • 208.64.201.169
  • 162.254.199.136

TCP: (only these two IPs sent any TCP packets back)

  • 65.55.223.37
  • 208.64.201.169

So for some reason it appears that my Mac, and only my Mac, isn't doing something right. Any clue what could be causing the connection to fail?

Update:

It definitely looks like a DNS issue - Google Chrome provides an error DNS_PROBE_FINISHED_NO_INTERNET. Also, I can do telnet 216.58.218.206 80, and then interestingly enough it waits and waits and waits, but then it connects. After which

GET / HTTP/1.1
Host: google.com
Content-Accept: */*

Returns with the Google 301 redirect to http://www.google.com

  • It isn't necessarily the Mac doing something wrong, you cannot conclude that yet. It sounds like the default gateway wasn't set on the Mac. Can you check to see if a default gateway is set, and if so, to which IP? If the default gateway is not set, it could indicate a problem with your dhcpd configuration on the Raspberry Pi. – jksoegaard Nov 22 '16 at 13:15
  • @jksoegaard according to the instructions I found on some other site, I went to system prefs > network > advanced > tcp/ip and I found Router: 172.16.1.1, so I believe it's set properly. I'm updating the question with some more information that I've discovered – Wayne Werner Nov 22 '16 at 15:12
  • Looks like this is definitely a DNS issue - when I add 68.105.28.11, which I'm guessing is my ISPs DNS it seems to work fine? – Wayne Werner Nov 22 '16 at 16:49
  • Sounds like your dhcpd configuration is set to send out wrong DNS-servers? what is listed for DNS in the configuration file on the rPi? – jksoegaard Nov 22 '16 at 21:36
  • @jksoegaard see my answer - the DNS is actually fine, I guess it had something to do with the routes on the macbook. – Wayne Werner Nov 22 '16 at 22:48
1

It looks like something was horked up with my routing table. Flushing my routes with

$ sudo route -n flush

at the terminal several times, clearing my custom DNS entries, and turning my wifi off and then on again allows me to connect properly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .